Homematic Dimmer doesn't accept 100 percent


i’m having problems using 100 as percent value for Homematic IP Dimmer HmIP-FDT.

There are currently two dimmers of this kind installed and both don’t accept 100 as percentage value. It i try to set to 100 visibly nothing happens.
The event log shows that the value has been set, but was directly set to last value.

2019-03-18 19:49:16.803 [ome.event.ItemCommandEvent] - Item 'Test001' received command ON
2019-03-18 19:49:16.805 [vent.ItemStateChangedEvent] - Test001 changed from OFF to ON
2019-03-18 19:49:16.806 [ome.event.ItemCommandEvent] - Item 'UG_SZ_Dimmer_Level' received command 100
2019-03-18 19:49:16.808 [nt.ItemStatePredictedEvent] - UG_SZ_Dimmer_Level predicted to become 100
2019-03-18 19:49:16.810 [vent.ItemStateChangedEvent] - UG_SZ_Dimmer_Level changed from 49 to 100
2019-03-18 19:49:16.812 [vent.ItemStateChangedEvent] - UG_SZ_Dimmer_Power changed from 57 to 117
2019-03-18 19:49:16.813 [GroupItemStateChangedEvent] - Wattages changed from 172.00 to 232.00 through UG_SZ_Dimmer_Power
2019-03-18 19:49:16.951 [vent.ItemStateChangedEvent] - UG_SZ_Dimmer_RSSI changed from -64 to -65
2019-03-18 19:49:16.962 [vent.ItemStateChangedEvent] - UG_SZ_Dimmer_Level changed from 100 to 49
2019-03-18 19:49:16.963 [GroupItemStateChangedEvent] - Wattages changed from 232.00 to 172.00 through UG_SZ_Dimmer_Power
2019-03-18 19:49:16.964 [vent.ItemStateChangedEvent] - UG_SZ_Dimmer_Power changed from 117 to 57

The highest value i can set is 99, anything higher than 100 is ignored completely, so 100 seems to be a valid value.

So long this issue didn’t hurt me so much, i just had to use 99 instead of 100 as max value. But today i connected my instance with homekit and google assistant and speech commands like “full brightness” try to set 100 percent, so you have to say “… to 99 percent” which sucks a little bit.

Possible workarounds may be to create a global rule or sth, but i would prefer to use the default behavior.

I’ve already searched for settings at CCU3 interface but couldn’t find anything helpful.

Does anyone has similar problems or knows a solution for this?

Homematic IP components are controller over Homematic CCU3 V3.43.15

  • Platform information:
    • Hardware: Synology DS918+
    • OS: Docker Image (openhab/openhab:lates)
    • Java Runtime Environment: 8
    • openHAB version: 2.4.0

You’re not alone

Looks like some kind of rounding issue in the binding perhaps.

If you change the item from Dimmer to Number what happens?

Bug report: https://github.com/eclipse/smarthome/issues/6841

For the Google Assistant problem, I have a rule as workaround:

rule "Fix TV-Licht"
  Item HM_TVLicht_3_Level received command 100 or
  Item HM_TVLicht_3_Level received command ON

Thanks for your answer, but this seems generally not to work.

Could not cast 90 to org.eclipse.smarthome.core.library.types.PercentType

I tried 90, 0.9 and 90.0.

Thanks for your answer, i added a +1 to the issue.

This kind of rule i also had in mind as workaround, nice to hear that it works!

Yesterday i installed firmware V3.43.16 on CCU3 and it changed the behavior a little bit. If i set the dimmer to 100 percent it stays at 100 and doesn’t fall back to last value.

I modified the rule to list alls items which have to be fixed:

rule "Fix Dimmer"
  Item UG_SZ_Dimmer_Level received command 100 or
  Item UG_WZ_Dimmer_Level received command 100