Homematic HmIP-BWTH no values

(Homer Sim) #1

Hi,
I am fearing that I have to ask you a lot more in the future because I bought some HM stuff and want to get it running.

Setup:
CCU3
Openhab 2.4.0 in docker container
Homematic Binding installed

What I did so far:
pairing HmIP-BWTH with CCU3 - is working
configured bridge in PaperUI - is working
added things in my things file

Thing HmIP-BWTH 000C98A9A98400 // Bad-Thermostat

added items to my items file:

Number BadThermostatLuftfeuchte “Luftfeuchte Bad [%.1f %%]” (gOG,gOG_Bad,gTemperatur_Alle) { channel=“homematic:HmIP-BWTH:ccu3:000C98A9A98400:1#HUMIDITY” }
Number BadThermostatTemperatur “Temperatur Bad” (gOG,gOG_Bad,gTemperatur_Alle) { channel=“homematic:HmIP-BWTH:ccu3:000C98A9A98400:1#ACTUAL_TEMPERATURE” }

Checked if things are linked to items in PaperUI - yes it is

added dummy widgets and linked one to temp and one to humidity with these formats:
grafik
grafik

When I did this it showed both values. After I played a little with more actors etc. Temp is not showing any values in PaperUI I receive NaN
grafik
What is wrong?

Thanks

0 Likes

(Martin Herbst) #2

In order make sure that everything works correctly I would use the auto discovery in Paper UI instead of definition the things manually. You will then see the correct names. I can remember a problem with HMIP devices and the correct casing.
If the thing appear in Paper UI than you can be sure that the connection and data exchange between OH and the CCU works correctly.
I am using the Homematic binding, too. I am using a mixture of Paper UI configuration and text files, i.e. I have configured the bridge in Paper UI and then used the auto discovery to create all things. I am using text files only for my items.
If the auto discovery does not detect all devices you should check the firewall settings on the CCU.

0 Likes

(Homer Sim) #3

Maybe I missed this. I had issues with the firewall settings but these were solved and things were automatically detected. This is where I have the channel info from for items file.
But while writting these lines I am wondering if a redundancy could be the issue. I have auto detected things in PaperUI and a things config file …?!

0 Likes

(Martin Herbst) #4

I never tried it, so maybe this can cause problems.
I can also remember that running openHAB in a docker container can cause problems because the Homematic binding needs quite a lot ports and all must be available within the container.
If the removal of the things file does not help you can try to enable the trace and check the messages in openhab.log.

The “old” Eclipse Smarthome github project contains some solved (and some open) entries regarding Homematic and Docker (https://github.com/eclipse/smarthome/issues).

0 Likes

(Homer Sim) #5

Thanks for your hints.
I found some strange thing:

why is homematic missing in this list? It is installed in PaperUI

0 Likes

(Martin Herbst) #6

In version 2.4 it was named org.eclipse.smarthome.binding.homematic. This will be changed back to org.openhab in the near future.

0 Likes

(Homer Sim) #7

With deleting the thing entries in conf file and rebooting of openhab solved this issue. Except the settings for the bridge.
all values are now displayed again.

Thanks

0 Likes