Homematic HmIP-STHD does not communicate with openHAB


I tried to integrate my first Homematic IP device and now I’m struggling on the last steps.
I read all about Homatic IP in openHAB and followed all the recommendations
but still have not succeed. Here comes what I did and what is not working.

I have Homatic HmIP-STHD device. This is a temperature and humidity sensor.


  • Homematic CCU2 with the latest SW (IP components supported)
  • openHAB 1.8.3
  • Addons 1.9.0
  • homematic:homematicIP.enabled=true in configuration
  • HmIP-STHD connected to CCU2 without problems. Values available on CCU2.
  • XML-RPC protocoll enabled on CCU2
  • All datapoints HmIP-STHD available
  • Item available in openHAB (Number Temperature “Temperature [%.1f °C]” {homematic=“address=0001D3C990Bxyz, channel=1, parameter=ACTUAL_TEMPERATURE”})

Item is not updated with new values.
I get a new value if I reboot openHAB or if I reboot the CCU2.
In the openhab log and also in the homematic binding DEBUG log the IP device does not show up.

Any ideas if I have missed something to enable the homematic IP support?
Do I have to enable something additional on CCU2 that the values are distributed over XML-RPC interface?

BTW: I have ~30 Homematic standard components running, all with no problems.
It’s just my first IP device that drives me crazy.

Now I found out that the values are updated if I reload the datapoints:

Switch Reload_Datapoints “Reload Datapoints” {homematic=“address=BidCoS-RF, channel=2, parameter=PRESS_SHORT, action=RELOAD_DATAPOINTS”}

So if I get it right the homematic binding does not recognize the value change in teh CCU2 automatically
but gets the updated values by reload request.

Next step is now to find out if it is a CCU2 problem or a binding problem.

Hello have you found the fail?

No. But honestly I haven’t tried it.
What I do is that I reload the datapoints each 5 minutes.
To get the temperature of my wine cellar it is enough.
For other devices it would not be an option. So I stay with the non-IP homatic components.

Hallo können wir in Deutsch schreiben?
Ich bekomme keine Daten angezeigt. Wie haben sie die Items formuliert

English may help also others.

Make sure that your device is connected to CCU2 or whatever you are using
and values can be seen on hommatic side.

Here is an example from my IP Sensor HmIP-STHD connected to CCU2 (Address faked):
Number Wine_Temperature “Temperatur [%.1f °C]” (wineT_Chart) {homematic=“address=000E9569A24xyz, channel=1, parameter=ACTUAL_TEMPERATURE”}
Number Wine_Humidity “Luftfeuchte [%.1f %%]” (wineH_Chart) {homematic=“address=000E9569A24xyz, channel=1, parameter=HUMIDITY”}

To reload the datapoints I use this:
Switch Reload_Datapoints “Reload Datapoints” {homematic=“address=BidCoS-RF, channel=2, parameter=PRESS_SHORT, action=RELOAD_DATAPOINTS”}

Hi Frank,

Are you reloading the datapoint or do found a different solution?


I still do a reload of the datapoints.
It works for me and I haven’t tried to solve it other.

Meanwhile the CCU2 got several updates.
So maybe it would be worth to try again the normal way without reload of
If I find some time I will try. Thanks for the trigger.


I opened a new thread in the meanwhile.

I have oh 2.2 and the latest version of CCU firmware. Still does not work.

I have seen that the problem might be on the side of the device, This device is not updating even the CCU GUI.
I you go on the CCU GUI and change the temperature set point, suddenly the actual temperature and humidity are updated.
What I did is to create a rule with a cron task and update the the set point temperature back and forth. This updates the actual temp and humid as well. This might be better then a full refresh.

Do you do this rule on the CCU2 in the internal program area or with openHAB?
What is the delta time for the rule? How often do you run it?

on openhab I made the rule, though would be interesting if this would work also when defined on CCU.
I tried to define empty programs, with temp and humid as input params, this did not work.
I thing the setpoint temperature should be changed through a CCU script, this might trigger an update of the temp and humid.

I tried it with a program on the CCU2 but with no success. I guess this special device needs some external trigger.
With an update of the temperature set point it also works for me. But I do not toggle the value.
I just send one value each minute with the item option forceUpdate=true. This works well.
But also my first approach with reloading all datapoints works well and I see just missing values updated with this option.
So we have least to options for the IP device. I never bought an other IP device after this hassle. So I do not know if it is a problem also for other IP devices or just this special one. Also I have v1 of the HMIP-STHD. There is a v2 available but no firmware in the download area to update.

Correction: So we have at least two options for the IP device.

I did not understand if this reload data points reloads whole set of values from CCU, including system variables. If so it might be some overhead. Additionally this will not trigger the value transmission from the device to the CCU. I realized that although the value (temp/humid) changes on the device the value is not transmitted to the CCU, because the device thinks there is no value to do this and waste battery power. It does not have any clue that we need this value in CCU/openhab. I thought that defining a program on CCU will change something in this matter which is not the case.
On the other side it seems other than the standard battery powered HM device, this HP-IP device seems to listen all the time and if values are updated from CCU, it also sends changed values back.

I think the only option is to force an update of the value in order to get real-time values.
Could you please look at the CCU GUI does the last update value match your refresh cycle, if not you are not updating values from device.

I have additional HM-IP devices which seem to do ok, though these are switches and motion sensors. I think the future is HM-IP, as you can see all new devices are HM-IP. I hope the CCU support will be enhanced or even better we shall get new CCU HW/Firmware asap.

Any updates? Fetching exactly same issue w/ Hm IP RHS…