Homematic HMIP-WRC6 do not fire rule


I use OpenHAB 2.2.0 stable and a few Homematic components with CCU2.
Now I am trying to integrate a 6 button wall-mount remote control (HMIP-WRC6).

Configuration in the CCU2 ist complete and works fine. A dummy program to catch the short-presses is already done.

In OpenHAB thing is added via autodiscovery in Paper UI and the items (Switches) for every button (press short and press long) are defined manual in an items configuration file. Link for each channel is shown in Paper UI correctly. I am now trying to catch a short press-event in a rule, but nothing happens. The item-state do not changes also.

My item-definition:

Switch Schalter1_kurz "Wandschalter 1"    {channel="homematic:HmIP-WRC6:b9c5de93:XXXXXXXXXXXXXX:1#PRESS_SHORT"}

The when-part of the rule:

Item Schalter1_kurz received update or
Channel "homematic:HmIP-WRC6:b9c5de93:XXXXXXXXXXXXXX:1#PRESS" triggered SHORT

If I press the button 1 I receive in debug-mode this event:
16:42:33.922 [DEBUG] [communicator.AbstractHomematicGateway] - Received new (Boolean) value 'true' for 'XXXXXXXXXXXXXX:1#PRESS_SHORT' from gateway with id 'b9c5de93'
But no event for the item or the rule.

Ist there anybody who can assist me with this problem?

Thanks and regards,


You have to create an (empty) link (Verknüpfung) in the CCU2 for each Channel, otherwise the events aren’t visible in openhab.

Guess that’s what he did saying “A dummy program to catch the short-presses is already done.”

I had the exact same issue these days. Restarting the binding in the console using

stop org.openhab.binding.homematic
start org.openhab.binding.homematic

seems to have solved it.

Hi Jens,

thanks for your reply.

I have already created the empty link in the CCU2. That’s what I mean with “A dummy program to catch the short-presses is already done.”

Hi Mirko,

thanks for your reply.

Restarting the binding don’t solve the problem.

In the meanwhile, I have set up a fresh OpenHABian installation on a second RPI, with only the homatic binding.
But no change - logs are the same.

Any other ideas?



Please try

  Item Schalter1_kurz changed from OFF to ON

I’ve three switches running with this trigger and everything is working fine. I assume it’s not a binding problem.
Could you also please check the event log like

tail -500lf event.log | grep Schalter1

After that, please press a button and have a look, what is written to the event log.
I assume also, that you have created such a dummy rule on the CCU2 for short and long keystrokes for each button? The screenshot shows the configuration for long keystrokes, the rule for short keystrokes. So I’m a bit confused.

Thanks for your reply.

I’ve reseted the CCU2 and set up a new OpenHAB installation. Now the Switch works fine and all updates are shown in OpenHAB. Configuration ist still the same. I don’t know what worked wrong, but I’m happy that it works now.

Regards, Tobias