Homematic IP Steckdose

Hallo everybody,
I’m trying to bind a new Homematic IP Steckdose with Openhab. Since It does not work with the Openhab Binding, I was trying with Program on CCU and rule on Openhab.
I tried with the following procedure but with no results…: (It should work)
I even cannot get a Log to understand what I’m doing wrong.
Can anybody help?

Thank you



***on CCU2 I created a Rule to turn on and off the Plug:
Condition: If… HMIP-PS 000213C9XXXXXX:3 when ON “Trigger when changed”
***and the other one:
Condition: If… HMIP-PS 000213C9XXXXXX:3 when OFF “Trigger when changed”

**** Item:
Switch IP_Plug_1
Switch IP_Plug_1_on “Plug 1 ON” {homematic=“program=Plug_IP_1_ON”}
Switch IP_Plug_1_off “Plug 1 ON” {homematic=“program=Plug_IP_1_OFF”}

*** Sitemap
Switch item=IP_Plug_1 label=“Plug 1 ON/OFF” icon=“socket”

**** rule:
rule "Plug IP"
Item IP_Plug_1 received command
switch(receivedCommand) {
case ON : {
sendCommand(IP_Plug_1_on, ON)
logInfo(“IP Plug 1”, “Triggered CCU program to switch ON”)
case OFF : {
sendCommand(IP_Plug_1_off, ON)
logInfo(“IP Plug 1”, “Triggered CCU program to switch OFF”)

You should try IP_Plug_1_on.sendCommand(ON) respectively IP_Plug_1_off.sendCommand(ON)

Ah. And maybe the rule isn’t triggered at all, because the UI does not send a command but only a change, so try
when Item IP_Plug_1 changed and switch(IP_Plug_1.state)

Thank you Udo,

but still not working :-/
It’s driving me crazy. I just would like to make a HomematicIP Steckdose work wit my Homematic.
The plug if I use the Homematic web interface works fine.

If you have any suggestion, would be much appreciated.


Are there any log entrys from the rule yet?

Sorry for the late reply, but today I was working…
I just came back and run the log. This Is what I get now, but still does not switch on the plug. :frowning:

The following log is for a test ON and OFF in sequence.

21:28:42.611 [DEBUG] [m.r.internal.engine.RuleEngine:305 ] - Executing rule 'Plug IP switch state' 21:28:42.611 [INFO ] [runtime.busevents :22 ] - IP_Plug_1 received command ON 21:28:42.621 [INFO ] [runtime.busevents :22 ] - IP_Plug_1_on received command ON 21:28:42.621 [DEBUG] [.b.h.i.c.HomematicCommunicator:243 ] - Received command ON for item IP_Plug_1_on 21:28:42.621 [DEBUG] [o.o.b.h.i.c.client.CcuClient :202 ] - Executing program on CCU: Plug_IP_1_ON 21:28:42.634 [INFO ] [.o.model.script.IP Socket 1 ON:53 ] - Triggered CCU program to switch ON 21:28:44.720 [INFO ] [runtime.busevents :26 ] - IP_Plug_1_on state updated to OFF 21:28:44.720 [DEBUG] [.h.i.communicator.ItemDisabler:98 ] - Disabled Item IP_Plug_1_on with binding ProgramConfig[name=Plug_IP_1_ON] 21:28:45.805 [DEBUG] [m.r.internal.engine.RuleEngine:305 ] - Executing rule 'Plug IP switch state' 21:28:45.806 [INFO ] [runtime.busevents :22 ] - IP_Plug_1 received command OFF 21:28:45.808 [INFO ] [runtime.busevents :22 ] - IP_Plug_1_off received command OFF 21:28:45.809 [DEBUG] [.b.h.i.c.HomematicCommunicator:243 ] - Received command OFF for item IP_Plug_1_off 21:28:45.809 [INFO ] [o.model.script.IP Socket 1 OFF:53 ] - Triggered CCU program to switch OFF


The Program in the CCU was set up incorrectly. It was triggering, but I forgot to tell the program to execute a change of state of the device :blush:

Thank you Udo, you’re hint helped me out!. :thumbs:

One more thing:
I think there’s an issue with the actual Binding, because I often get this error:
> Disabled Item IP_Plug_2_off with binding ProgramConfig[name=Plug_IP_2_OFF]

Actually i do not know what is the significate of this log line…