Homematic: Log: Invalid byte 1 of 1-byte UTF-8 sequence

Hi all!

My OH2b3 installation on my Raspberry 3 does not find couple of Things of certain homematic (CCU2) sensor types (eg HM-LC-Dim1PWM-CV, HM-TC-IT-WM-W-EU). All other sensors are identified and added correctly. In the openhab.log the following message appears for each of these sensors:
2016-06-13 20:28:42.009 [WARN ] [ternal.communicator.HomematicGateway] - Can’t load device with address ‘MEQ0479341’ from gateway ‘ccu’: Invalid byte 1 of 1-byte UTF-8 sequence.

Another OH2 installation on my Mac, however, does find and add these Things.

Best Regards,

I have tried several builds of openHAB 2 and got different results:

  • On my Raspberry 3 I am using a Homematic binding with version 2.0.0-SNAPSHOT and date June, 4th (I think this is the Beta 3 package of OH2) and everything runs fine without this message.
  • On Windows 10 today I tried it with the latest build (Snapshot timestamp is 20160619.010131) and I got also the same message.
  • I have also a development in Eclipse on Windows 10 and I pulled the latest sources from GitHub before the test: here also everything is OK

Hi there,

I now have also tried OH2b3 on a Win10 machine with the same error message and the same amount of homematic items found/not found. On my OH 1.8.3 setup (Raspi3), however, all items are found.

On the CCU2 I get the following error message in the log:

Jun 13 20:51:54 homematic-ccu2 user.err rfd: XmlRpcClient error calling event({[methodName:“event”,params:{“RF-ccu”,“LEQ1283646:2”,“ACTUAL_TEMPERATURE”,22.300000}]}) on
Jun 13 20:51:54 homematic-ccu2 user.err rfd: XmlRpc transport error`