Homematic on OH3

Tags: #<Tag:0x00007f174f343088> #<Tag:0x00007f174f342d18>

Currently i migrate from openHAB 2.5.7 running on a Pi3 to openHAB 3.0 runnig on a new x86 Intel based NUC with Ubuntu 20.4 and also docker.

I have problems with the homematic binding. The CCU2 works fine with the OH2.5.7 but when I disable it there and create a new thing in OH3 I got a timeout. OH3 finds the CCU and prints its serial in the log. I have already tryed to reboot the CCU, I also flashed the newest firmware. Both OH Versions are running on Docker with network mode “Host”.

I have no idear what to try next.

Hi, Homematic has problems to feed two running Openhab instances. I experienced the same. You need to stop openhab 2.5.7 first. If i recall correctly, just disable the binding or the bridge in 2.5.7 is not sufficient.

That is true.
I wrote I disabled the bridge in OH2.5.7 and the create the new Thing in OH3.0

Now I tryed to set the Callback ip to NUC and it worked for about a minute. OH3 discovered all items, but then lost the connection,

2021-01-26 09:29:20.029 [WARN ] [ommunicator.AbstractHomematicGateway] - Connection lost on gateway ‘ccu’, cause: “No Pong received!”

and spams the log with

2021-01-26 09:30:53.941 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler HomematicBridgeHandler of thing homematic:bridge:ccu tried updating channel DUTY_CYCLE_RATIO although the handler was already disposed.

any idears?

just to recap, you opened OH 2.5.7, disabled the bridge, kept this openhab instance open, started OH3 and added the bridge there? Correct?

if yes, as far as i remember this caused an issue on my side as once CCU is connected to one instance of openhab, then move to a new instance without really closing down the first one properly ( disabling a running bridge is not sufficient in my experience and that was my point )

for OH3, i just put in the IP address and keep gateway type to AUTO, everything else empty in the binding. No issues with connection

BTW i am on CCU2

Yes this is correct.

I disabled it in oh2.5.7 then reboot the CCU and then create a new thing in oh3

I use also the CCU2

Maybe a Network issue with docker and docker-compose?
but Network mode is host for OpenHAB

i am using the same here, docker on Synology, host.

Can you try to shut down 2.5.7 instance before adding to 3.0., not just rebooting CCU2. just in case.

i can’t help with the log entries though.

That is the next try, but this works only when I’m alone in the house.

So I tryed Shutdown OH2.5.7, then reboot ccu, then start oh3.0 and create new Homematic thing. Still the same issues!

sorry to hear, i am running out of ideas now what else you could do. maybe the log file does ring a bell to someone else?

Next I try to install OH2.5.7 instead of OH3.0 on the new NUC to ansure that there is no network issue.

I put the IP instead of name in the callback field and it worked.