Homematic On_Time_Automatic not working


while modifying some of my rules I figured out the OTA for my switches are not (no more) working.
Is there a known bug with OH3(.1 M4) in the homematic binding?

I can set the OTA number item to a value but the related switch doesn’t switch off after this time has expired. Just stays on forever.
The OTA feature was working as expected within the same rules on OH2.5

My environment:
OH3.1 milestone 4 in a docker container on raspberry 4 5.10.17-v7l+
using RaspberryMatic V3.57.5.20210424 as bridge
to connect to a HmIP-MOD-OC8

TIA for any feedback

Hi Michael,

nothing was changed on purpose :-). But I found some issues with other HM items that were caused by some changes in OH core.

Can you please perform the following steps:

  1. Enable log mode DEBUG for the HM binding
  2. Set an “On time” value
  3. Check openhab.log whether there are any messages related to this change and post the excert of the log file.

Hi Martin,

txs for your reply.
By your step

you triggered an idea with me.
I haven’t had an On_Time item for this channel. But an On_Time_Automatic item which I am using to set the time value.
So my first step was to create an On_Time item. Which immediately after creation changed from NULL to the value I had applied to OTA and the OTA functionality starts working as expected!
So my lesson learned, please correct or confirm:

  • On_Time_Automatic isn’t a functionality provided by HM or HM-IP but by the OpenHab binding
  • In order to have it working you will need to have the On_Time item for the same channel defined. Even if you aren’t using it in your rules/sitemaps.

Cheers and thanks

The device has got data points named “ON_TIME”, i.e. the binding creates a channel with the same name and this one will be used to communicate directly with the device.

I have searched the Java code and your assumption is correct. on_time_automatic is created by the binding :-).