Homematic: StatusDisplay HM-Dis-EP-WM55 supported?

Hi all, I also have trouble getting the HM-Dis-EP-WM55 to work, but while the text is working well, I cannot react on the key presses.
My configs:

Switch Status_Entrance_Bottom                   "Eingangsstatus Taste unten"                                                                    {channel="homematic:HM-Dis-EP-WM55:ccu:NEQ1596256:1#PRESS"} 
Switch Status_Entrance_Bottom_s                 "Eingangsstatus Taste unten kurz"                                                               {channel="homematic:HM-Dis-EP-WM55:ccu:NEQ1596256:1#PRESS_SHORT"} 
Switch Status_Entrance_Bottom_l                 "Eingangsstatus Taste unten lang"                                                               {channel="homematic:HM-Dis-EP-WM55:ccu:NEQ1596256:1#PRESS_LONG"}  

rule "open garage gate by Status_Entrance"
    Item Status_Entrance_Top received command or
    Item Status_Entrance_Top_s received command or
    Item Status_Entrance_Top_l received command
    logInfo("Status_Entrance", "triggering garage gate")
    if (Gate_Garage.state == OPEN)


Sending and receiving text lines work (but there is no reaction to my rule, neither logging nor text lines), so in general the setup is ok. Any suggestions?

When pressing long, I get the error “Unknown value ‘CONT’ for PRESS virtual datapoint, only SHORT,LONG,LONG_RELEASE allowed”, is this related?

Which version of the binding are you using? This error message looks familiar to me and as far as I know a similar problem has already been solved.

I am using 2.2.0 according to the bundle list.

There was a problem with “CONT” which was fixed in January 2018. This was after the release of 2.2. You could try with the latest snapshot release.

Ok, I will give it a try, thank you. This is probably not to be discussed in this thread, but are the addon releases bound to the main OH version number? There should be maintenance releases of addons inbetween two OH releases. At least, I was hoping to get bugfixes easier and continuously by switching to the package distribution of OH. I don’t mean to be rude (my comment is rather general than specific to the homematic addon), but manually installing snapshot versions was pretty much what I was hoping to avoid. I will try it nonetheless.

maybe this was not such a good idea after all. Now updated all to… and nothing is working anymore. Karaf is not starting many bundles, among them core, ui, the bindings, transformations etc… I know what I’ll do for the rest of the evening…

Hmmm, I have tried 2.3 Build 1221 and no problems with a clean installation (on Windows). But I did not test it with production environment on the raspi.
So good luck …

Some feedback from my testing…
Button presses work when reacting on “changed to ON” events, not “received command”.
Text transmission only works for lines 2 and 3. The button descriptions cannot be changed, and also the 3rd line in the middle (presumably line 4) cannot be set. The EP-Thing has only 3 lines, not 5.
Did someone manage to change the button text or the 3 middle line?

It is definitly not possible to change the button texts via the binding, but the three lines in the middle can be set (at least with binding version 2.1). I am not at home, so I can’t post my rule code, but I can check it this weekend and post the rule code here.

That would be awesome. Please post if it works with v2.1 and also which line numbers appear where on the display.

I created a slightly modified version of my rule that is running on OH 2.1:

rule "Info-Anzeige"
    Item Fenster_Arbeitszimmer changed or
    Item Fenster_Bad           changed or
    Item Fenster_Schlafzimmer  changed or
    Item Tuer_Wohnzimmer       changed or
    Item Balkon_Temperatur     changed

   val temp = "Line 1"
   sendCommand(DT_L1, temp)
   sendCommand(DT_Icon1, "OK")
   var fensterIcon = "OK";
   sendCommand(DT_Icon2, fensterIcon)
   sendCommand(DT_L2, "Line 2")
   sendCommand(DT_L3, "Line 3")
   sendCommand(DT_Icon3, "ON")
   sendCommand(DT_Submit, ON)  // always execute at the end

Item DT_L1 ist connected with channel DISPLAY_LINE_1, DT_L2 with channel DISPLAY_LINE_2, …

The result of this rule looks like this:

The texts “CCU Line 2” and “CCU Line 3” can only be set on the CCU.

Thanks a lot for the good feedback! Well, my lines are off by 1, so when I write to line 2, it appears where you have line 1. Text written to line 1 does not appear anywhere…
I assume it is related to this update, where @Thomas_G mentioned that the lines have been shifted? I think it made things worse for the EP device. Could you make that last change only for the OLED version and revert for EP?

What binding version are you using? I could try it in my environment, too.

@gerrieg What do you think? Would it be feasible to use different channel names for the EP device?

I am using the snapshot.
How can I manually change a single binding (I installed with apt-get)?

These devices are driving me crazy :disappointed_relieved:

A summary for me, there are two devices with display:

  • HM-DIS-WM55 -> OLED -> 5 lines -> but @Thomas_G says 6 lines???

  • HM-Dis-EP-WM55 -> E-Paper -> 3 lines -> lines are shifted by one. If i revert my change only for the EP device, it should work again.

Can someone confirm my assumptions for the EP device?

@gerrieg Yes, they are really “interesting” devices :-).

Strictly speaking, the EP device has got 5 lines. But via the binding only the 3 lines in the middle can be set (see my picture above). In version 2.1 of the binding there were 3 channels for the text and 3 channels for the icons:

In the next days I can find some time for testing (and probably migrating my production environment to 2.3).

The OLED HM-DIS-WM55 device has 6 lines. Your changes made the device completely usable. (One more line and shifting the content one line up).
For the EP device you must revert the shifting-change. But only for EP, not for “my” device.
I think that is the only “To-Do”.
That’s what I interpret here.

Hi @gerrieg, did you have time to fix this issue? Would help me a lot because right now, I cannot use the device properly. When you make the changes in a snapshot I can test it right away.

@yannick_hein Thanks for the ping, i forgot to create a PR :frowning:
see https://github.com/openhab/openhab2-addons/pull/3444

By the way, that did it! Works for the EP device now, thx!