HomematicIP-Devices offline with 2.4.0 Snapshot 1330


I did update from snapshot 1328 to 1330 today and I see that all my HomematicIP-Devices are offline now. Did somethinmg change here?

Device with address ‘0000D3C9905BF8’ not found on gateway ‘MEQ1608148’

I already cleared the cache and tmp without success. CCU and all other Non-IP devices are working.

Does someone else see this? In the meantime I’m running it in DEBUG-Mode to see what’s going on. This seems to be the issue:

2018-08-16 06:09:28.782 [TRACE] [nal.communicator.client.BinRpcClient] - Client BinRpcRequest:

2018-08-16 06:09:28.794 [TRACE] [al.communicator.client.SocketHandler] - Returning socket for port 2001
2018-08-16 06:09:28.800 [TRACE] [nal.communicator.client.BinRpcClient] - Client BinRpcResponse:
_ faultCode=-3_
_ faultString=Unknown paramset_

2018-08-16 06:09:28.803 [DEBUG] [tic.internal.communicator.CcuGateway] - RpcMessage RPC failure (-3 Unknown paramset), fetching metadata with TclRega script for device: MEQ0737879, channel: -1, paramset: VALUES


I have the same problem.
Spendet hours, resseting the CCU2 and the Openhab Server
getting [ommunicator.AbstractHomematicGateway] - Can’t load device with address ‘001898A99262EA’ from gateway ‘LEQ1010457’: -3 Unknown Paramset: VALUES (sending <?xml version="1.0" encoding="ISO-8859-1"?>

kind regards

Hi Michael, you are not the only one, same situation for me.
Upgraded today and all Homematic IP devices went offline.

Verified this with a 2nd install of Openhab.
After install of 2.4.0 #1330 all Homematic IP devices went offline.
Downgraded to 2.3.0, all Homematic IP devices went online.


How can i roll back to a working 2.4 release?
2.4.0~20180810173814-1 doesn’t work.



As far as i know you can’t. You can go back to 2.3.

Aah ok,

but the “modern” KNX config will also work with 2.3?!


If you are using Apt, the commands you want are:

sudo apt-cache show openhab2

Look for the version you want to rollback, then

sudo apt-get install openhab2=2.1.0~2017030108541

Replacing everything on the right of the ='s sign with the correct information for the one you want to roll back to

Repeat the same with openhab2-addons.

Also you may need to uninstall / reinstall the Bindung afterwards. That worked for me.


Rolled back to 2.3.0-01 and all is fine…


It is not jut for IP devices. I have the same problem with no IP devices.

Same over here, also Not Ip devices.

Problem stays with build 1338

Error Message point to some RSSI stuff

Fixed in snapshot 1340! I already updated and all devices are working again :slight_smile:

I confirm, my setup also works again. Good work.


I just stumbled upon this thread, unfortunately after updating to 2.4.0~M2-1 which is still broken for me!

My setup is OpenHab 2.4.0~M2-1 connecting to Homegear (version 0.7.27-1824) all on one RPI (using openhabian).

All homematic devices are offline (I have non IP devices only) and I see java.lang.NullPointerException in RssiVirtualDatapointHandler. All other things are working fine.

018-08-28 22:40:00.216 [ERROR] [ematic.handler.HomematicThingHandler] - null
java.lang.NullPointerException: null
	at org.eclipse.smarthome.binding.homematic.internal.communicator.virtual.RssiVirtualDatapointHandler.handleEvent(RssiVirtualDatapointHandler.java:56) ~[?:?]
	at org.eclipse.smarthome.binding.homematic.internal.communicator.AbstractHomematicGateway.handleVirtualDatapointEvent(AbstractHomematicGateway.java:705) ~[?:?]
	at org.eclipse.smarthome.binding.homematic.internal.communicator.AbstractHomematicGateway.loadChannelValues(AbstractHomematicGateway.java:488) ~[?:?]
	at org.eclipse.smarthome.binding.homematic.handler.HomematicThingHandler.loadHomematicChannelValues(HomematicThingHandler.java:377) ~[?:?]
	at org.eclipse.smarthome.binding.homematic.handler.HomematicThingHandler.doInitializeInBackground(HomematicThingHandler.java:137) ~[?:?]
	at org.eclipse.smarthome.binding.homematic.handler.HomematicThingHandler.lambda$0(HomematicThingHandler.java:92) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]

Thx. Markus

I also tried Snapshot 1341 yesterday evening and went back to 1340. HomematicIP-Devices are offline in 1341 but working in 1340.

@Kai Is the issue back or do we have something different here?

Stupid me :frowning:
The Milestones are built from https://github.com/openhab/smarthome/tree/oh and I have missed to rebase that branch - hence it does not include the HMIP fix, sorry!
Will do a M3 later today with that fix…