Homeseer HS-FS100+ Light Sensor is unkown device

Tags: #<Tag:0x00007f387068fa60> #<Tag:0x00007f387068f830> #<Tag:0x00007f387068f5b0>

@chris
First must thank you @Chris for all the great work on the zwave binding and database.
I have tried to add this sensor but it keeps coming up as an unknown device. It produces an xml file and I have attempted to add a different device to the database using that xml file.
I get the warning : “Device with these IDs is already in the database as HomeSeer Technologies, HS-FS100-L and endpoints are already defined.”
This device has an additional 5th configuration parameter that the HS-FS100-L doesn’t have so I guess it would be the same hardware with different firmware?
I am not sure how to proceed from here.
I can post the xml if that would help.

What version of OH are you running?

It is openhabian openHAB 2.4.0-1

If it is listed in the database yo may need to update your binding. I asked in another thread how to do that.

I am not seeing it in the database.
I only see this one: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1026
which does not have the 5th parameter listed and but the type and ID are the same.
I was following the database guide for adding a device but now am stopped at raising the issue with @chris so he can decide how it should be handled.

Yes, please post the xml file.

You are probably correct that we need to duplicate the database to add a new version for new firmware, and then add the new parameter…

As requested by @sihui, please post the XML generated by OH and we/he/I can work out what to do.

1 Like

Thank you both.
Here you go.
network_0184c5b6__node_118.xml (9.3 KB)
Let me know what else I can do.

New device with same type/id with new firmware limits:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1069

That is great Thank you. So to get the database update on my machine, I would do what? I am running Openhabian 2.4 Stable.

Upgrade your zwave binding to the latest 2.5 snapshot, please.