HomeSeer HS-FS100+ Z-wave sensor problems

  • Platform information:
    • Hardware: _Raspberry Pi 3 Model B Rev 1.2/1gb/16gb
    • OS: openhabian (very current)
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.5.1-2
  • Issue of the topic: I’m learning how to use this and have settled on zwave sensors for some of the new stuff, and am sticking to known-operable devices and planning out how to populate my network, populating it, then making the interfaces pretty.

Zwave stick: Zooz S2 stick (zst10). I have decided to avoid using unencrypted Zwave for everything for the moment.

I have installed a Stelpro Zwave heater controller (node 5), and it’s working well. Other successful (non zwave) adds are tplink switchable outlets, Chamberlain garage doors, and a haiku fan.

I’m using two HomeSeer HS-FS100+ flex sensors with flood detector cable.

Both flood sensors were setup, and paired successfully according to instruction - nodes 7 and 8. One is operating pure battery, the other powered, for testing. These are the “5 parameter” version (some apparently 4?), supposedly patched properly in 2.5 and I should have the fixes. The openhab device description/configuration has the correct corresponding parameters in the documentation for the device’s cheat sheets.

I can see them in Paper and habpanel. I am expecting to see something more. For example, I believe I should be seeing their temperature sensors. The channels are all there, but always shows blank/N-A-N for the temperature channel. The “switch” seems to do nothing whatsover. Dunking a sensor in water does nothing.

It’s connected, obviously, but the protocol may not be working?

Suggestions? I’m very new, so I need a little hand-holding if you want samples of files or logs. Maybe I should give encryption a try.

I’ve also gotten a Zwave Aeotec Indoor Siren 6, which may have config/connect problems of its own, but I’m going to leave that until I get the flex sensors working, and maybe I’ll be smarter then.

Thanks in advance.

That is why getting debug logs is described in the binding documentation under the title when things do not go as planned.

I am using the same stick with no issues. I think encryption adds unnecessary complexity except for door locks and other security devices.

I turned on logging, tried the switch via paper, and got this:

2020-02-12 11:58:47.054 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 7: Command received zwave:device:db38487f:node7:switch_binary --> ON [OnOffType]
2020-02-12 11:58:47.059 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 7: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 0 not found
2020-02-12 11:58:47.063 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 7: No messages returned from converter

I deleted node7 via paper (didn’t touch the zwave adapter), re-scanned and created, could actually see the COMMAND_CLASS_SWITCH_BINARY for endpoint 0 being created, but when I try to flip the switch, I still get the same sequence of errors.