Have a new Rpi3b

Tried to install using:

  • Three different 16GB micro SIM cards
  • Tried to use Etcher and Win32diskimager to burn the images
  • Tried to use SD card formatter and Windows to format SIM cards
  • Tried both these builds: openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz and openhabianpi-raspbian-201804031720-gitdba76f6-crc9e93c3eb.img.xz

So far 11 attempt to install and all failed. Some similarities:

  • All installs failed with this error " Setting timezone based on IP geolocation… FAILED" And why - shouldn’t be that difficult to find the time zone from my ISP’s IP address.
  • Most installs reported: “Cloning myself… FAILED”, but for a few it succeeded
    But all installs ultimately failed. However with an encouragement that a reinstall would very likely succeed - however 0% success.

I’m truly amazed that this is even possible. Standard hardware - software as recommended - where could the culprit be?

Check your Power Supply, for RPi 3 is recommended 2,5A good quality PSU.


Hi @Mogens_Lunde,

Sorry to hear you’re having problems. It sounds like you might not be alone. Hopefully we can get this sorted out quickly.

My time zone always fails but OH does install. RPi4 Openhabian.img install

…Wild wild guess … do you have a dual router/NAT set up? ie. Is the external IP for router that the RPi connects to actually the wan side IP?

Another even wilder guess… DNS… anything like piHole doing the DNS?

Thinking is this … if pi is standard, Openhabian image install method standard then the problem lies elsewhere… maybe in the network environment.

Thanks Rafal, I bought a “Raspberry Pi 3 Official Desktop Starter Kit” (brand new) so the PSU is the one delivered with the pi. But will try to use another PSU just in case this one is faulty.
Also I will try to burn the SD card on some other device - so far I have used the same burner :slight_smile:

Thanks Mark, The network is standard and apart from the issue with timezone, the pi seem to be able to communicate just fine with the internet.

Just posted the same for a topic about RPI 4. :upside_down_face:

Install Raspian OS on the RPI then use apt-get to install OH.

For the openhbian-config tool you can add it with:

# install git
sudo apt-get update
sudo apt-get install git

# download and link
sudo git clone https://github.com/openhab/openhabian.git /opt/openhabian
sudo ln -s /opt/openhabian/openhabian-setup.sh /usr/local/bin/openhabian-config

# execute
sudo openhabian-config

Have tried a few more things today - all to no avail:

  • Tried to use another cardreader
  • Tried yet another SD-card - this time a sandisk where the others were Kingston
  • Have made a factory reset of my router

Have not been able to find an alternative power source, but I cannot see much possibilities now other than trying to buy a new pi.

The latest logfile looks like shown underneath. Should mention that after the install I can login to Openhabian, but not much idea in doing that I guess when the installation is faulty.

2019-07-10_01:21:39_BST [openHABian] Starting the openHABian initial setup.
2019-07-10_01:21:40_BST [openHABian] Storing configuration… OK
2019-07-10_01:21:40_BST [openHABian] Starting webserver with installation log… OK
2019-07-10_01:21:46_BST [openHABian] Changing default username and password… OK
2020-04-05_14:45:53_BST [openHABian] Setting up Ethernet connection… OK
2020-04-05_14:45:53_BST [openHABian] Ensuring network connectivity… OK
2020-04-05_14:45:53_BST [openHABian] Waiting for dpkg/apt to get ready… OK
2020-04-05_14:46:18_BST [openHABian] Updating repositories and upgrading installed packages… OK
2020-04-05_14:51:55_BST [openHABian] Installing git package… OK
2020-04-05_14:52:17_BST [openHABian] Cloning myself… OK
2020-04-05_14:52:20_BST [openHABian] Executing ‘openhabian-setup.sh unattended’…
2020-04-05_14:52:20_BST [openHABian] Checking for root privileges… OK
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists…
2020-04-05_14:52:27_BST [openHABian] Loading configuration file ‘/etc/openhabian.conf’… OK
2020-04-05_14:52:27_BST [openHABian] Setting timezone based on IP geolocation… FAILED
2020-04-05_14:53:21_BST [openHABian] Setting locale based on openhabian.conf… OK
2020-04-05_14:54:55_BST [openHABian] Setting hostname of the base system… OK
2020-04-05_14:54:55_BST [openHABian] Setting the GPU memory split down to 16MB for headless system… OK
2020-04-05_14:54:55_BST [openHABian] Enabling Audio output… OK
2020-04-05_14:54:56_BST [openHABian] Installing basic can’t-be-wrong packages (screen, vim, …)… OK
2020-04-05_14:55:46_BST [openHABian] Installing additional needed packages… OK
2020-04-05_14:56:09_BST [openHABian] Installing additional bluetooth packages… OK
2020-04-05_14:56:39_BST [openHABian] Adding slightly tuned bash config files to system… OK
2020-04-05_14:56:39_BST [openHABian] Adding slightly tuned vim config file to system… OK
2020-04-05_14:56:39_BST [openHABian] Downloading and setting up FireMotD… OK
2020-04-05_14:58:05_BST [openHABian] Installing Java Zulu 32-Bit OpenJDK… OK
2020-04-05_14:58:52_BST [openHABian] Installing or upgrading to latest openHAB release (stable)… Warning: apt-key output should not be parsed (stdout is not a terminal)
gpg: no valid OpenPGP data found.
FAILED (apt)
2020-04-05_14:59:07_BST [openHABian] Initial setup exiting with an error!

Er hat sounds like the problem reported Here

Many thanks Jürgen! Seems I have chosen a bad time for this project - must be an error in the package when you seemingly need to edit three files with x’es.
I’m logging in via SSH, and here using the uid/pw: openhabian/openhabian. This works. I can also change to the folder /opt/openhabian/functions/, but why do the system ask me for a password when trying to sudo -e openhab.bash?

Why, a Linux expert might be able to say. I can only say that if you logged in as user openhabian and want to commit the first sudo command in that session you are always asked to give the password.

In other words, I am NOT a Linux expert but I am not hopeless ( that you have a running openhabian installation soon).

Stay healthy!

Thanks a lot!!! I managed to get things up and running thanks to the thread you linked to. Many thanks - have wasted most of the weekend due to what seems to be an error in the package file. What I did was a sudo openhabian-config, and updated/-graded various stuff, and after a reboot (which is done by typing “Sudo reboot”) everything worked, and I am not at the stage where I can start to connect my devices. Now the fun part starts, so for now back in business :slight_smile:

Right it’s a bad time but you didn’t read that linked thread properly.
There is a problem with a repo signing which is beyond our reach that made installs terminate, but that was fixed. But it seems you have not retried since as many reported back success.

Because it’s not setup to allow for editing files that way (as no user should be in need of that).

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.