Hov do I get dimmer slider to update position based on KNX dimmer feedback in OH3?

  • Platform information:
    • Hardware: RPI 3B
    • OS: Openhabian
    • openHAB version: OH3

I am struggling to get OH dimmer slider to update to real value after using physical knx switch to dim the light. If I Switch on/of with my knx wall switch, Openhab updates status automatically seemingly without reading GA for switch status. This does not work with dimmer value for some reason, even though I added the dimmer status channel and linked to dimmer item in OH3.

I used group monitor In ETS and the KNX dimmer is sending out dimmer value feedback as DPT 5,001 Percentage.

I try to use semantic model by building locations and adding thing channels as equipment or point.

I Have tried added the dimmer in OH3 both as equipment and as point. Both functions to control dimming of light, but will not receive dim status. I am not sure if I understand the difference between point, item and equipment yet… 6 days since I first tried to configure OH to control my KNX system.

Any idea what I do wrong or how to solve this?

A detailed look at the autoupdate feature that you have noticed.

This is probably the part you need to look at more closely, not locations and points.
Get your device updating the openHAB Item.
Show your Thing channel settings to see if someone KNX familiar can help.

Thanks. I have read trough everything you posted. I also read somewhere that if the item receives 2 status updates ut has to chose witch to follow. My KNX dimmer sends both switch and dimmer value status and I suspect my item chooses to follow only switch status…
Any idea how to make it chose dimmer status instead of switch status?

I think part of the solution might be disabling the autoupdate function in OH3 and rely on actual status sent by knx thing instead.

I use UI to configure OH3. I can’t find an auto update function anywhere. When I enter item to edit, the code options doesn’t show so I can’t edit text file either…
Any suggestions how and where to change autoupdate function?

Adding pictures of my config


UID: knx:device:ec1a9f65c0:959d8642bd
label: D2 Dimmer 4 Channels
thingTypeUID: knx:device
pingInterval: 2
address: 1.1.2
readInterval: 2
fetch: true
bridgeUID: knx:ip:ec1a9f65c0
location: Tavle

  • id: Ch4
    channelTypeUID: knx:dimmer
    label: Kontor Taklampe
    description: “”
    increaseDecrease: 1/1/7
    position: 1/2/7
    switch: 1/0/7
  • id: Ch2
    channelTypeUID: knx:dimmer
    label: Spisestue DownLight
    description: “”
    increaseDecrease: 1/1/5
    position: 1/2/5
    switch: 1/0/5
  • id: Ch3
    channelTypeUID: knx:dimmer
    label: Spisestue pendel
    description: “”
    increaseDecrease: 1/1/6
    position: 1/2/6
    switch: 1/0/6
  • id: Ch1
    channelTypeUID: knx:dimmer
    label: Hjemmekino taklampe
    description: “”
    increaseDecrease: 1/1/4
    position: 1/2/4
    switch: 1/0/4
  • id: Ch4_Switch_status
    channelTypeUID: knx:switch
    label: Kontor taklampe bryter status
    description: “”
    ga: 1/4/7
  • id: Ch4_Dimmer_value_status
    channelTypeUID: knx:number
    label: Kontor taklampe dimmer verdi
    description: “”
    ga: 1/5/7

That can’t happen. One Item update at a time using one piece of information. For a Dimmer type Item that must be a percent type 0-100, there is no Dimmer Item OFF state, only 0%. You might have two updates in quick succession of course.

What a binding might do with a message like “state on, power 50%” is up to the binding, so somewhere in your KNX settings. I cannot advise on that part.

It is indeed an Item feature. You will find you can add it as Item metadata.

This is not going to fix the underlying problem if you are not getting the correct status from KNX, but might make it clearer.

When you see states UNDEF that generally means the binding/channel is in trouble somewhere.

when I switch off with physical knx wall switch, the dimmer responds with both switch and dimmer status off/0% according to GA monitor.
When I dim down, Divaer responds with sending a dimmer value status telegram only.

Looks to me like my knx system is doing what It should.

Wault must be within binding or item as far as I can se…

As I said, I cannot advise on KNX configuration, but I can say that making separate channels for dimming, switch, and status is not usual, example -


I use files for things so I cannot really compare my setup with yours. Anyhow, I’ve configured dimmer like this in my things file .

Type dimmer        : rac1dimmer        "Stue"      [ switch="2/2/1+<2/3/1", position="2/2/2+<2/3/2" ]

2/2/1 is the switch ON/OFF
2/3/1 is status of the switch ON/OFF
2/2/2 is set dimmer value
2/3/2 is status of dimmer value