How can I play files via Allplay Binding?

I am new to OH, running OH 2.5.9 in a Docker Container on a QNAP NAS.

The Allplay Binding finds my Panasonic players and already plays radio streams.

WZ_StreamURL.sendCommand(“http://streams.harmonyfm.de/harmonyfm/mp3/hqlivestream.m3u”)
:white_check_mark:

I succeed in playing mp3 files via playsound

playSound(“bell.mp3”)
:white_check_mark:

Unfortunately I do not succeed in playing mp3 files which are stored on same QNAP and also available via DLNA.

WZ_StreamURL.sendCommand(“file://192.168.1.21/MUSIK/Test.mp3”)
:x:

I am not sure how files, available on NAS as well as via DLNA shall be addressed.
Is it just that I fail in interpreting the correct path on the NAS or is there anything else to be checked?
Additionally I would like to understand how complete directories or playlists can be played.

Thanks for any hints.

  • Platform information:
    • Hardware: QNAP NAS
    • OS: Docker Container
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.5.9

Comparing the file:// access that also can be used in a browser to open a file that is available on a local or mapped drive I would try something like:

WZ_StreamURL.sendCommand("file:///MUSIK/Test.mp3")

assumed that /MUSIK is a share that is mounted to the root. Yes, there are three /s.
Do you have a web server on your QNAP ? Then you could use the http protocol or try to create a playlist.

Thanks for the hint.
MUSIK is indeed a share folder on the NAS with the IP 192.168.1.21 and my default mp3-Player plays Test.mp3 when entering following in the explorer command line.

file://192.168.1.21/MUSIK/Test.mp3

Openhab does not succeed with any of the following commands

WZ_StreamURL.sendCommand(“file:///MUSIK/Test.mp3”)
WZ_StreamURL.sendCommand(“file://192.168.1.21/MUSIK/Test.mp3”)

In PaperUI Control I can see that the Allplay State is briefly changing to “TRANSITIONING” and then to “STOPPED”. No Error Message in Openhab.log.

In my opinion the problem are access rights. The Openhab-Container runs on the NAS but with different IP and I have no glue how to grant Openhab access rights to the MUSIK share folder.

Actually I think anyway that access via DLNA would be better but there again I have no idea how to adress correctly.
On my Android-DLNA Player I find the file as specified in the DLNA server under “TS253B/Musik/Ordner/MUSIK/Test.mp3”
I tried following with and without Port without success. Then I stopped trial and error as I neither do not know whether the path “…/Musik/Ordner/…” is required nor if “.mp3” is needed.

WZ_StreamURL.sendCommand(“http://192.168.1.21:8200/TS253B/Musik/Ordner/MUSIK/Test.mp3”)

What else can I try or is there any more detailed log level available to find out why Allplay stoppes playing?

I do not know the Allplay binding. In case you haven’t done yet increase the loglevel for the binding to see if more details will be logged: https://www.openhab.org/docs/administration/logging.html

how did you do that via explorer ? The explorer also is executed from a different IP address. Do you have to login with username and password ?

I accessed via my notebook where the NAS-network drives are connected and access codes are stored. So, no surprise that it worked.
But Openhab runs on the NAS in a Container with different IP address, so I assume it has no access rights and I do not know, how to grant OH or the Container access. I succeeded to SSH the QNAP and container but I do not want to play arround there as I do not want to crash my NAS.

With regard to logging I added to “org.ops4j.pax.logging.cfg” following lines but could not see any difference in “events.log” even after restarting the container. Obvisually I misunderstood the logging instructions.

Allplay Logger

log4j2.logger.Allplay.name = org.openhab.binding.Allplay
log4j2.logger.Allplay.level = DEBUG
log4j2.logger.Allplay.additivity = false
log4j2.logger.Allplay.appenderRefs = Allplay
log4j2.logger.Allplay.appenderRef.ZWave.ref = Allplay