How can I re-discover a thing that I just deleted?

I’m using a Zigbee Binding and I’m trying to re-discover a device that I just removed. The device (an Aqara Wireless Switch without a Neutral line) has been discovered initially and I was able to control it successfully via the application. However, then I moved the switch to another room (further away from the controller) and it stopped working. So, I thought I should try to remove it and add it back again. Since then I tried all I could think of to make it visible again:

  • I restarted the OH2 instance (version 2.4 on a Raspberry Pi 3) several times
  • I removed all the items and links (using the smarthome:links / smarthome:items clear commands)
  • I removed all the things related to this device in particular.

I don’t know what I could try anymore… the logs don’t show anything when I try to discover the device.

Anybody, any idea what am I doing wrong ?

Thank you !

maybe try resetting the device. I don’t know how to do it on your particular device but usually pressing and hold button until blinking or some such. Find the documentation for the device.

Oh, I’ve done that every time I tried to rediscover it…

Clear cache and restart mayb? Have you tried that?

1 Like