How do I find the Yeelight ID?

Trying to link Yeelights. Installed the binding but nothing discovered automatically.
The manual process requires an ID. Where do I find the bulb ID?

Have you tried the yeelight app and turned on developer mode, or reset the light to see if OH can discover it?

1 Like

The yeelight binding won’t find the bulbs, but the Xiaomi IO binding does.
But I’ve opted to purchase a Xiaomi gateway as I understand it will be simpler to use as I get more and more Xiaomi devices

Not sure it’s a good idea as a lot of post show problem on the last gateway firmware, port for binding are close on some gateway. Look at zigbee2mqtt project for other xiaomi devices.

Hi, I had same problem and found the solution for Linux users.
Prerequisites:

  • Yeelight app
  • Python and Pip installed
  1. Open Yeelight app and run “Lan Control” as described here: https://www.yeelight.com/faqs/lan_control

  2. in Linux Terminal run “sudo pip install yeelight” to import yeelight library for python

  3. In linux Terminal run “python” to access to the python console (terminal now prompts “>>>”)

  4. type “from yeelight import discover_bulbs” and press enter

  5. type discover_bulbs() and press enter (lan control in yeelight up must be activated).
    Instrunctions here: https://yeelight.readthedocs.io/en/latest/

After few seconds the console prompts something like this (at the bottom of the image you can see the deviceid):

4 Likes

Nice find and hope this will help others.

Also Windows 10 has a new subsystem for Linux commands. Not sure how well it works as I mainly use Linux but here’s a link for how to. https://docs.microsoft.com/en-us/windows/wsl/install-win10

If someone uses this and find it works please post back to let others know.
Thanks

@G4rpez_G4rpez Thanks a lot for the tutorial - what might be the reason why it doesn’t find a light strip and a LED bulb that just arrived from China a couple of days ago while older Yeelight ceelings are auto discovered both from the pyhton script and openHAB. LAN is enabled.

Thanks for your How-to but I’ve a trouble.
I run openhab on Centos 7 with firewalld enabled.
When the firewall is enabled I can’t discover my Bulb when Firewalld is disabled I can.

I’ve try to :

firewall-cmd --permanent --zone=public --add-port=1900/tcp
firewall-cmd --permanent --zone=public --add-port=1900/udp
firewall-cmd --reload

Without success

How can I resolve that ?

Tried the above. the Id showed once. specifically after I had installed library and only after I had rebooted the system. since then it only shows

[ ]

Nothing else… I still managed to copy the id over to OH but the binding is not connecting