How do I get the InsteonPLM to respond to X10 commands?

I have gotten a basic InsteonPLM binding working under OpenHAB2.

I’d like to be able to respond to X10 RF remote signals. I have successfully sent X10 commands from the UI that control a particular switched lamp. The same switched lamp is controlled by one button on my HR12A X10 rf remote. And it sends the signal to a second X10 on the same house/item code.

But the InsteonPLM seems to be unaware of the remote signals. I used insteon terminal to try to see signals that were being received (modem.startWatch()) and never see a signal go by… though I’m uncertain whether I should. Should something exist in the modem’s database for the x10 units? There isn’t for the device that it is already controlling…

What would be the correct item syntax for the remote? I’ve tried setting up “Switch” and “Contact” with no success with either.

Any suggestions or samples you can point me at are appreciated.

Thank you!

It’s been a good while since I implemented X10 support, and I no longer have any devices with which to trigger X10 messages. I don’t remember any linking process between the modem and X10 devices. But I remember that the modem would pick up X10 messages from e.g. a remote control.

This fellow seems to also have problems getting the modem to pick up X10 control messages:

Don’t know how to make progress. If the insteonplm debug log or insteon terminal in watch mode do not produce messages, then the problem is likely somewhere else.

Could you point me at the page that shows how to set up the insteonplm debug log? I haven’t been able to get this working…

While we’re at it, is there an easy way to disable all logging? I’m running on a smallish flash drive that I’d like to keep from filling up…


search google for the insteonplm wiki, it’s described there in the trouble shooting section.

Thank you!

One question: do you remember if the PLM needs to be setup as a Responder to an X10 address before it will pass along any X10 messages that are on the power line?

I don’t remember doing anything like that. I’m not sure even how a modem db
table entry for that would look like, given the different size of insteon
and x10 addresses.

Well, I just tried modem.addResponder(“A.1”,0x01) and it worked, although nothing came of it. No reports from the modem when an X10 command was sent… In the database, interestingly, it registered that address of 00.00.66.

Searching, I noticed that there may be modes that this modem needs to be put in. I see a description (here and here) saying that there is an Insteon Only, X10 only, and Insteon and X10 Combo Mode. But I can’t find the developer sheets that would have anything about the command that would set those modes. Do you have that documentation? Is this something that rings a bell at all?


No, never realized that there these modes, nor do I know how to switch
between them. Googling didn’t help either.

I did find one thread indicating that others have problems with that too.
Plus a bunch of misinformation:

Hi, I’ve posted some of my configs and logs on the thread mentioned above that may help to illustrate the problem.

So, I figured out my problem… It was as simple as the age-old “on the other side of the AC line” problem that X10 and Insteon both suffer from. When I moved my X10 transmitter onto the same power strip as the insteonplm, suddenly it worked.

Now I use my remote to broadcast a completely different house code (B1, for example) and use openhab and the insteonplm to translate it and rebroadcast as A1. I do that so that I hold the remote button long enough for the whole system to register the signal.

It seems to be working great! I’m translating X10 to Insteon commands, setting off timers, and just generally seem to have it integrated into the system!


Hi, I’ve also solved my problem by using ‘received update’ instead of ‘received command’. I’ve posted the new working rule on the other thread.