How do I mount a raspberry samba share on a Linux mint desktop?

  • Platform information:
    • Hardware: raspberry pi 3+ and Linux mint desktop
    • OS: openhabian to Linux mint
    • Java Runtime Environment:
    • openHAB version: 3.2
      How do I mount a samba share from my raspberry pi open habían system to my Linux box? The docs give the command for windows and Macs but not linux. I’m not a native Unix speaker but I have some experience. When I tried to mount it I got a mount with a .kar extension that my linux box insisted was an audio file. I’ve never used samba. This should be a one line command and a similar one line to add to my fstab file.
      I can see the openHab shares by running
      smbclient -L OPENHABIAN.local
      I just can’t figure out how to mount it on my desktop so it’s useful

There is a step by description at ( step 4 describes the part on the client side ).

Looks like there are multiple defintions for .kar files.
One seems to be Karaoke MIDI file ( which your system thinks it is ) an other one is KAR .
That mounted directory contains a file with a .kar extension ? Files with that extension contain e.g. the OH application.

You can & should use NFS to mount the share but this is off scope of this forum so please g**gle for that.

Ok. Thanks, that looks similar to what I tried but I’ll try that again in a little while referencing this doc.

@mstormi About all I know is that NFS is different from the windows FS and, I assume since you said that, it is different from samba. I assumed that since the samba shares were pre-setup on the openhabian install that that was the way to go. Briefly, what does NFS buy me that samba doesn’t?

My goal is to use VS Code, with which I’m pretty familiar, for editing. I have tried to include a weather widget that I copied the code from GitHub. It doesn’t display correctly, I can’t see anything obviously wrong and I can’t believe this was developed within the openHab custom widget editor. I have been able to setup the remote development extension in Vscode but I think I need the shares anyway.

The NFS user and file permissions match the way Linux works while samba is Windows centric. File locking, file events, and permissions will all work much better when using NFS when both machines are Linux than samba will. (A note for future readers, Windows 11 (10?) now comes with NFS support, but you have to execute a few Powershell commands to enable it. I recently had to get a Windows machine because there’s no Linux version of Fusion 360 nor Lightburn :frowning: .).

If it is a MainUI Widget, the only way it could have been developed was within the openHAB custom widget editor. And if that’s what it is (if it’s YAML then indeed it is a custom widget) the only way to install it will be to copy that YAML from GitHub to the custom widget editor unless it happens to be published to the Marketplace in which case it can be installed like an other add-on under Settings → User Interfaces). openHAB does not support MainUI widgets from anywhere except the JSONDB and you should not be editing the JSONDB with VSCode.

For what purpose? It’s not a rhetorical question, I just want to know what you need to do with these files beyond editing that would require more than the Remote VSCode extension provides. There might be another/better way.

Ok. That is enough reason. I have developed a strong dislike for windows. The only thing I use it for is an old windows laptop to VNC into my Linux machine. Do I need to go to my habían install and setup NFS shares. I think I saw a doc at the same place ref’ed above that did that.

Well, shot down again… I thought I could put that big hunk of widget code into VScode, tweak it appropriately, the just save it back to where it was supposed to live in the openHab hierarchy. That apparently is not possible… I guess I just cut and paste it back.

Is there some way to see what is going on in the widget when it runs? Like I do with c++ in vscode debugger.


Yes, openHABian doesn’t do NFS for you. It’s not hard, just different and beyond the scope of this forum really. One thing I will recommend is that you create the same users with the same UIDs on both machines for the most seamless experience. Though there are other approaches you can take too if you prefer. As with most things Linux, you’ve lots of options. :slight_smile:

You can bring up the console log in the browser. It’s usually going to be under “Developer Tools” or somewhere like that depending on which browser you are using. Don’t forget that is where the widget is rendered and where it’s running. I don’t think widgets can log anything themselves (it’s just a YAML config after all) but you should be able to see what MainUI, and F7 are doing with the config.

When using the Custom Widget builder in MainUI, you also get some feedback when there are errors in the config and you can experiment a little more freely. There is also an expression tester in the developer sidebar (alt-shift-d) where you can test out expressions. That’s super useful.

At this point, I’m not even certain that the widget you are referring to is a MainUI widget. Care to share the link? Maybe you are trying to shove a HABPanel Widget into MainUI?

This is the thread that I found the coed. It is the weather card widget and I copied the code from GitHub. It looks like it is a MainUI yaml widget but I’m not sure I understand completely yet what that really means.
Weather card
I didn’t get a chance to work on the file shares today.

Oh, that weather widget. Yes that’s definitely a MainUI widget.

I don’t think that’s made it to three marketplace so you’ll need to “instead” it by creating a new widget under Developer Tools → Custom Widget and paying the YAML from GitHub.

The widget has a number of parameters that need to be set once you add a widget you’ll need too set the parameters. There is also a lot of prerequisites that need to be met with how your the things and items are configured. But you shouldn’t have to edit the widget code itself to make it work.

Ok, thanks. Thai is what I’ve been doing. The problem usually turns out that I’m not seeing something obvious, like a bad or missing parameter. But I’m a retired programmer so I gravitate to blaming and looking at the code.