How to add ABUS CFA3010 smart lock to openHAB?

I’ve spent a lot of time and read a lot of comments about the ABUS CFA3010 smart lock integration with the openHAB. I’d like to summarize my knowledge about this subject to hopefully save your time if you’ve encountered the same issues.

My configuration:

  • Raspberry Pi 3B+
  • openHAB 3.4.1 with Z-Wave binding
  • Aeotec Z-Stick Gen5 (it does not support S2 protocol)
  • ABUS CFA3010 Z-Wave smart lock

To handle the ABUS CFA3010 smart lock, follow these steps:

  1. Install smart lock on the door
  2. Reset smart lock to factory settings (manual 5.6)
  3. Configure the fitted drive from factory settings to work with your door lock (manual 5.3)
  4. If your Z-Wave controller does not support the S2 protocol, change the default security protocol from S2 to S0 on the ABUS smart lock (manual 5.5)
  5. In your openHAB instance navigate to: Administration > Settings > Thigs > Add new (“+” sign in the bottom right corner), then click on the Z-Wave binding and click Scan button.
    Important note: Devices like smart locks need to be paired with the Z-Wave controller using security protocol S0 or S2, otherwise system won’t recognize them correctly. The only way to do this is to use the Scan button in your openHAB instance. This will set your controller into inclusion mode. Do not unplug your controller from the openHAB server during this operation!
  6. Once you clicked the Scan button in your openHAB instance, you have about 30 seconds to pair your smart lock with the Z-Wave controller (manual 5.4).
  7. After the device is paired and the Scan progress bar is complete, you should see a new thing in the openHAB inbox (sometimes you have to wait about a minute for inbox update). If so, add a new device and go to Thing details > Channels. You should see available channels like Door Lock, Alarm, Battery etc.

Possible problems:

  1. If the smart lock failed to pair, repeat steps 2 through 7.
    Unfortunately, a factory reset of the smart lock is required every time the inclusion fails, as this device must be paired in secure mode.
  2. If the smart lock is paired, but it’s not recognized correctly, you have to exclude it from the Z-Wave controller first and then repeat steps 2 through 7.
    To exclude smart lock from the Z-Wave controller, go to your openHAB instance and navigate to: Administration > Settings > Things, find your Z-Wave controller and click on it. Scroll down and click the Exclude Devices link. Your Z-Wave controller is now in the exclusion mode, so you can exclude the smart lock following the manual 5.4.
    To exclude a device from the Z-Wave controller, you do not need to use the openHAB GUI. You can simply disconnect the Z-Wave controller and exclude a device the old-fashion style by clicking a physical button on the controller.

If you encounter other problems, I encourage you to use Z-Wave Log Viewer. After uploading the /var/log/openhab/openhab.log file, it will filter it and display the Z-Wave logs in a very nice and readible format.

Have a nice day and good luck with your smart lock!

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.