How to automatically install HabPanel?

Hello Guys…
What to put in the addons.cfg if i wanna let OH2 automatically install HabPanel?
Ive tested "Habpanel"
i get this in the debug log:

Failed installing 'openhab-ui-Habpanel': No matching features for openhab-ui-Habpanel/0.0.0

Just add a line in your addons.cfg like the following:

ui = habmin,habpanel

HOWEVER, I suspect that you are on an earlier version of openHAB 2 and you will need to update before the above will work.

After upgrading to build #580 i still can’t install…
the addons.cfg

# A comma-separated list of UIs to install (e.g. "basic,paper")
ui = basic,paper,habpanel,habmin

the error in log:

Failed installing 'openhab-ui-habpanel': No matching features for openhab-ui-habpanel/0.0.0

Can you install it via Paper UI?

Reason I ask is that I had an issue a few weeks ago with my addons.cfg file, I still don’t know what was wrong but…

No it is still not listed in the paper UI… Also the problem with the Beta4

This should not be needed as HABpanel is no longer experimental, but worth trying.

It is activated… has tried enable/disable… no success…

Sorry, but I am now at a loss to what is wrong. I am sure someone else will jump in soon.

Thanks so far :slight_smile:


I’m having a similar problem. I was using a snapshot (not sure of a build number) with HABPanel included in Paper UI. After upgrading to snapshot #574, HABPanel disappeared from Paper UI (both, main screen and Extensions -> UI). Maybe it was removed from the snapshot builds?

Best regards,

I’m on 574 and it is working fine, upgraded from 572 with the
this line in the /etc/openhab2/services/addons.cfg

ui = basic,classic,habmin,habpanel,paper

Previously i a problem with habpanel not showing up on the main x.x.x.x:8080 ui selecter webpage but that was matter of browser cache cleaning.

yes i could understand that it could be a cache problem if it just didn’t show up, and in paperui says it is installed… But here i can’t install from paperui and also the log file says it can’t download and install the habpanel…

Anyone has a solution? Or a link to download it manually :slight_smile:

You should try the newest offline distribution, it doesn’t seem to have any problem.
If all else fails I suppose you could try downloading the .jar from$org.openhab.ui.habpanel/ and drop it in your addons folder.

Had similar problems after updating from beta3 to b4 with apt. Solution for me: sudo rm -rf /var/lib/openhab2/cache/* (Taken from: openHAB 2.0 beta4 has been released!)