How to change package?

  • Platform information:
    • Hardware: raspberry pi 3_
    • OS: openhabian
    • openHAB version: 2.1.0
  • Issue of the topic:
    In the first access to the webserver I set the package like Purely Ui. In this configuration I cannot see any old version binding. I need to add the knx binding but isn’t present in my paper ui.
    So I tried to add it changing the addons.cfg configuration file with the specification “knx” on line binding. I also changed in this file the line package to expert.
    How can I add the knx binding?
    How can I change the package setup to have more advanced features?

Set the “Include Legacy 1.x Bindings” setting in Configuration > System in PaperUI and all the 1.x bindings should show up in the list.

For 1.x version bindings, you append a 1 to the name of the binding when using addons.cfg. So to get the KNX 1.x verison binding it would be “knx1”. But be aware that you can only do either addons.cfg or PaperUI. You can’t do both. The addons.cfg will always take precedence.

The initial package selection only makes some settings and installs some initial bindings. Once OH is installed if you need to change you can make the settings yourself and install the bindings yourself as needed. The only way to select a different package is to install OH from scratch again.

Thanks for suggestions
I installed once more openhab to select the expert package.
In this way I can see the bindings with 1.x version and add the knx one. :v:t2:
Now I realized that the only way to work with this version of bindings is to modify knx.cfg file in openhabian. I’m a real beginner and I’m afraid I will not be able to do it. :sweat:
Do you think I could wait the 2.x version of knx binding? When can it be ready?

I have no idea. Only you know how much time you are willing to wait and how much time you are willing to spend learning how to do the configuration with text files.

The binding is fully documented here: