How to control Fakro ARZ solar roller shutter?

Tags: #<Tag:0x00007f433c714608>
  • Platform information:
    • Hardware:
  • Raspberry Pi 2 Model B Rev 1.1
  • USB Z-wave+ controller everspring
  • Fakro ARZ solar roller shutter
  • Fakro ZRH12 remote controller
  • OS: Raspbian GNU/Linux 10 (buster)

  • Java Runtime Environment: openjdk 11.0.3 2019-04-16

  • openHAB version: openHAB 2.4.0 Release Build

  • Issue of the topic:
    Hello openhab community!
    I am looking for help.
    I am totally new to openhab and zwave.
    I just bought this roller shutter and I noticed that the remote used zwave for the communication.
    I thought that it was a good occasion to start to use openhab.
    So far, I have openhab running, the USB stick is recognized (ONLINE).
    I found a zwave Thing “Z-Wave Node 004, Unknown Device”.
    |zwave_beaming|true|
    |—|---|
    |zwave_class_basic|BASIC_TYPE_CONTROLLER|
    |zwave_class_generic|GENERIC_TYPE_GENERIC_CONTROLLER|
    |zwave_class_specific|SPECIFIC_TYPE_PORTABLE_REMOTE_CONTROLLER|
    |zwave_frequent|false|
    |zwave_listening|false|
    |zwave_neighbours||
    |zwave_nodeid|4|
    |zwave_routing|false|
    |zwave_secure|false|
    |zwave_version|0.0|

I guess that it corresponds to the ZRH12 remote controller.
Unfortunately, I can’t see the roller shutter.
I don’t know exactly what to do next.
I tried to press the ‘P’ button during the “Searching for Things” but nothing happened.
I have seen that the roller shutter is in the list of supported devices, so somebody managed to do it.
I would like to control the roller shutter with openhab and/or the remote.

Any help is really appreciated.
Thanks!

First read the documentation and use Java 8. Nothing newer is supported currently.You sould probably update to a later zwave binding too. This script should help.

You should be able to operate your Fakro ARZ Solar roof shutters with openHAB 2.5 Milestone 3.

Please refer to the Fakro manual for including your ARZ Solar shutters into the Z-Wave network as they behave slightly differently from the ARZ Z-Wave (non solar) blinds…

I infer from your message that your ARZ Solar blinds are currently included in another Z-Wave network (a previous attempt). You should be able to remove an included roller shutter by means of any Z-Wave controller (EXCLUDE mode if I remember correctly).

1 Like

Hi Bruce,
Thanks for the advice, I downgraded my java version to 8 as you suggested.
I don’t know if it will help with my current issue but it will certainly avoid issues in the future.

The binding developer also advises upgrading to a binding newer than 2.4

Hi Olivier,
As you suggested I switched to the latest testing version of openHAB (2.5 M3).
For now, the result is the same, I can only find the remote control.
That’s probably because I don’t understand the topology of the Z-Wave network.
So I will try to exclude the shutter from the Z-Wave network of the remote and I will try to include it in the Z-Wave network of openHAB.
I will let you know the result.
Thanks

I have been working on cleaning up our database and this item appears to be missing some parts. A copy of the xml file generated by OH would help.
If the manual includes configuration parameters a copy of that or a link to the online version would help too.

I remember reading the documentation of the Fakro ARZ products and I seem to remember that the Solar blinds used some power optimizations, requiring a different controller to operate them.

Are you sure you have Z-Wave blinds?

If so, I’d try to reconfigure the Z-Wave network from the USB controller through HABmin or Paper UI. But first, set the log level for the Z-Wave binding to DEBUG in the Karaf console.

Hi Olivier,
This is the french documentation from their website:


My remote controller is different, I have a ZRH12.
I will try with the debug enabled.