How to disable content-encoding (gzip/brotlin) in openhab 3.4.0 main ui

Hi,

I run openhab behind a reverse proxy. This proxy injects some tiny additional javascript on each page.

After my upgrade from 3.3.0 to 3.4.0 it looks like the openhab main interface has enabled brotlin compression, which prevents my reverse proxy from injecting the javascript file.

Is there a way to disable it. I already searched for something related to karaf, but have not found anything so far.

I think it got added with:

looks like it is hardcoded :frowning:

just a short explanation why I need to inject a javascript file.


I embed the web ui in my own web application via an iframe.

during the page load, I show a loading gear as an layer on top. When the page load is done, the injected javascript file is executed in the context of the embedded page. It reads the embedded page title, triggers a message event and sends it to the top level window which hides the loading gear and displays the page title.

Please, someone, provide answer for this question!

What answer are you waiting for ?
It cannot be changed!
This has already been nswered.

The world is unfair to us! The Ruthless Power of Hardcoding ← RPoH

No, it is not unfair. We had to optimize the traffic going through the myopenHAB servers. That‘s one of the reasons why compression was implemented.

I understand you!
I (unexpectedly in 3.4) had to deal with a Microsoft IIS Reverse Proxy issue to bypass gzip.
There were no such problems in 3.3.

So there was a dream, so that instead of bypassing the problem, just turn it off:

gzip_compression false

Thanks, I got the answer, no need to look for how to turn it off anymore :))

If it could be turned off and everybody would do so, there would be no benefit on our servers.

@digitaldan Could it be feasible to have a config option to disable compression when myopenHAB is not used, respectively the addon is not installed ?

1 Like