How to enable Ethernet port of RPI3B+

Tags: #<Tag:0x00007f3879697f90>

Hi,
My Openhab2 server connected to with my router using Ethernet cable & it works fine…
Last night I suwiched on wireless for testing purposes.
Every thing works fine but sometimes ping breakes for a second because I kept RPI at another floor.now I want to set RPI back on wired connection.

How to disable wireless and get back with wired connection???

Please help!!!

Have you tried just plugging in the wired connection?
If that does not work, there is a way of programmatically disabling the Wi-Fi in NVRAM.

First I tried to connect Ethernet wire & entered wrong said & password then reboot pi, Assuming if wireless not connected then Pi will switch to wired connection…
But it not work.
Second I have disabled WiFi from etc/nety/interface file & reboot with Ethernet cable connected. It also Not working…

Perhaps some ideas here?

https://www.raspberrypi.org/forums/viewtopic.php?t=138610

I had the same issue. In my /etc/netwird/interfaces I’ve commented the wifi part.


# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

#allow-hotplug wlan0
#iface wlan0 inet manual
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp

thanks Marijn_Oudijk
this work. thanks for your support.