How to exclude a Z-Wave device with OpenHAB 3

I want to exclude a Z-Wave thing from the controller with OpenHAB 3. How can I set the Z-Wave controller to the exclusion mode?

I found the following in the documentation

"… To include or exclude a device in the network, set the controller into include mode, and press the appropriate button on the device to place the device into include mode. "

Does this really mean I have to do the same things if I were including a thing?

Or must I click on the “Remove device from controller” link of the thing, which I want to exclude?

The thing of the controller has a similar link, called “Exclude devices”. Is that the right link for starting the exclusion?

I don’t think so: I clicked on this link in error and noticed the controller went offline, which is not helpful to exclude devices :wink:
Fortunately nothing bad happened back then.

I would advise to follow the documentation. Worst case it will not work, you can then still try the other options you found.

I also saw this and also still do it the old way. Whatever the real way would be … The labelling is confusing I think.

What is the “old way”?

You’re right. It’s very confusing. The last time I excluded devices was with OpenHAB 2. I think I used openhabmin, but I think this UI doesn’t exist anymore in OpenHAB 3.

Good to know - I feared it might remove all devices at once.

The way described in the documentation did nothing. I think its wrong.

There is an “Exclude” option in the controller configuration (I forget the exact name and don’t have a system in front of me). Set this to true, and save the configuration. This will put the controlled into exclusion mode for 30 or 60 seconds (again, I forget the exact time).

1 Like


look for your bridge thing of the z-wave controller, there the setting is called “Exclude devices” at the bottom of the page.

I can’ find an “Exclude” option in the view of the controller configuration. Here is a screenshot:

Screenshot from the Controller configuration

And also in the advanced view I can’t see such an option:

Advanced view of the controller options.

But in the “Code” tab, I’ve found a “controller_exclude” options, which was set set to false. I’ve changed this to true and tried to exclude the device, but nothing happened. Here is a screenshot of the code tab:

Code tab of the controller

@chris do you see the option in one of my screenshots?

Are you sure? As @stefan.oh mentioned in his post, the controller is going offline after clicking at the “Exclude devices” button. I’ve just tried this and had the same result. However I took the device into the exclusion mode after clicking on the button. But nothing else happened. After a few minutes I restarted the Openhab server to get the Z-Wave controller online again. Every thing with the exception of the thing I want to exclude were going online again.

The thing I want to exclude is still there, but now it is offline.

Yes the same Happens Here as posted above.
At least in 3.0.1 …maybe this is already fixed.

However you can probably Just Use SCAN Like for inclusion for exclusion too

Excluding from the network does not remove the Thing from OH

It looks like it is fixed. In 3.1.0 Snapshot “Exclude Devices” works fine for me.


It is the “Exclude devices” link in your first screenshot. But I think you already figured that out.

I did a bit of debugging and this link clearly leads to several lines in the log, indicating the controller is in exclude mode. However, excluding devices was not possible in my case (OH 3.0.1). They still come up as online after rebooting OH. There were a lot of JAVA exceptions after the controller went offline. Seems I have to wait till OH3.1 as @konfetti mentions it is fixed there.

Edit: my exclude tests had unexpected side effects. Two of my devices were no longer part of the network afterwards, showing offline and the things were listed as “node not found” (or similar). These two devices wre not touched/part of the test. Had to do a factory reset of the devices and needed to include them again. :frowning:

At least I was able to remove the offline device by clicking at the “Remove device from controller” button.

I think, that the whole exclusion process is very confusing in OpenHAB 3 and it seems, that there are also some bugs in this process. I’m also missing a documentation for it. If that is right, then we should try to write a clear documentation how the whole process works.

I’ve openHAB 3.0.0 installed and for me the exclusion process looks like the following:

  1. Switch to the thing property page of the Z-Wave controller and click on the “Exclude Devices” button. I’ve marked this button with a blue line on the next screenshot. As a result in OpenHAB 3.0.0 the controller is going offline.
Screenshot Step 1

  1. In the next 30 seconds (default value, can be changed) you must put the device in the exclusion mode. In my case I had to push three times a little button in one and a half second.
  2. Reboot the OpenHAB server after waiting a few minutes to get the controller online again. The excluded device should now have the offline state.
  3. Switch to the think property page of the device, which should be excluded and click at the “Remove device from controller” button. I’ve marked this button with a blue line on the next screenshot. As a result, the think disapears in OpenHAB and is excluded.
Screenshot Step 4

Is that the correct way in OpenHAB 3.0.0?

As far as I can determine, the UI parts f that were developed with little if any input from the binding developer. Since the UI is not technically part of the binding but the binding documentation IS part of the binding, I am not sure where they would expect to document this. There is the potential for many Is and it cannot be expected the binding be updated just because somebody developed a new UI.

No basically almost all steps are wrong.
I will answer later from my Desktop.

In the image you showed I can see the exclude devices option, so it is there.

1 Like

Could you please explain what would be the right way? I’ve got OpenHAB version 3.0.2 , which is the current standard version of openhab3.

Here is an image from this thread where I highlighted the menu option.

I am now starting up an OH3.2 system. When trying to exclude a Z-Wave device I too didn’t succeed. I tried both the ‘inclusion’ method as in the binding description, which - predictably - doesn’t work. I also tried the ‘exclude devices’ in the controller, but nothing happens (except the controller going offline according to the log).
My Z-Wave stick has an LED that blinks when something is happening. During inclusion, it blinks as expected and inclusion succeeds without problems. During exclusion attempts, there is no blinking at all.
Next I moved the controller to my PC and started Sylab’s ‘Z_Wave PC controller 5’. The device to be excluded was indeed still there. Next I started the exclusion and the controller LED does start blinking during the exclusion period. After pushing the device’s button, it was properly excluded.
I connected the controller back to my Pi and only had to delete the device thing since it was obviously still in OH’s database.
My conclusion is that the exclusion process doesn’t put the Z-Wave controller into exclusion mode - hence nothing can be excluded. Could be either the UI or the binding, that’s unclear to me.