How to get 1.x bindings (insteonplm & myq) in latest OH2

How do I get 1.x bindings (specifically insteonplm and chamberlain myq) in the latest build:
openHAB 2.0.0~20170120171735-1 (Build #743)

I noticed documentation says 1.x bindings need to be enabled, so I turned this on:

after which they still don’t show up (only 2.x show) even when I restart, reboot, etc.

This switch activates the possibility to install a 1.x binding when a 2.x binding is also available

The insteonplm & chamberlain bindings are 1.x bindings, so this switch will not have any effect. It would have an effect if there were insteonplm 2.x and chamberlain 2.x bindings but you still wanted to install their 1.x versions.

You should have the bindings available in Paper UI:

Thanks Dim. I do not have those bindings available in paperUI.
Could I have done something during install (like select “easy” option or something)?

I have ONLY 2.0 bindings available.

not 100% sure, but I think the answer is yes (with “simple” you won’t see the 1.x bindings)

try switching to package = expert in your /etc/openhab2/services/addons.cfg and restart OH2

I’ll give it a try. Thank you again!

1 Like

You can also try this

which means add the last two statements to your addons.cfg

1 Like

Thank you both. I set:
package = expert
in /etc/openhab2/services/addons.cfg
and restart and that worked so I didn’t try the second suggestion, but…

all is good - again thank you.

1 Like