How to get OHA2 to install .jar files in addons folder

At the moment, I am trying to set up a manual install of OHA2 to have all the installation in one directory (and not spead over /usr, /etc, /var…).

With OpenHABian, my bindings in addons folder are recognized and installed, with my manual installation not! What do I have to do to make my installation see all .jar file in addons directory?

I am using current SNAPSHOT build and this tutorial to install:

Karaf console shows no bindings installed, although there is on in addons folder…

Can anybody help?

I’m using the manual install and bindings in /opt/openhab2/addons are working fine.
Make sure all files and directories have user:group openhab:openhab permissions.

I have already checked that… Please see here user & group of my addon:

-rw-rw-r-- 1 openhab openhab 50618 Feb 15 10:50 org.openhab.binding.avmfritz-2.1.0-SNAPSHOT.jar

I can not see any mistake here…

Hmmm, why are you trying to install a 2.x binding in a snapshot runtime build manually???

Actually, I cannot think of any usecase for that. It would only make sense if you have a stable runtime and want to add a snapshot binding version.

So just install the binding the recommended way via PaperUI …

Note that while manually installing an addon in your /addons folder, you need to take care of possible dependencies yourself.

1 Like


I need avm-fritz binding also supporting Comet DECT. Unfortunately, this version has not yet been integrated in OHA2 Snapshot builds…

I changed to Snapshot hoping that this Version is already built-in.

Okay, now we have a usecase :slight_smile:
It leaves the question open if there are any dependencies necessary for that binding …

Just a guess: did you try

bundle:start org.openhab.binding.avmfritz ?

No, I have not tried yet. I exactly have the same installation (only another Snapshot build) within OpenHABian. I simply put the binding upgrade into the addons folder, uninstalled the binding’s repo version, restarted the service and it worked! I could see all my configured things including the Comet DECT ones.

But within my manual install - nothing!

Just another question: Can OHA2-Users push the procedure to get an extended version of an already existing binding integrated into SNAPSHOT releases? If yes, how?

I don’t seem to understand how manual addon installation works.
The .kar file was downloaded into the addon folder, but it does not show up in paper ui.
When I click on the addon the paper ui still tries to download the addon.
Can someone elaborate how to manually install openhab1 and openhab2 addons?

I just put a jar file in the addons folder, after a restart it is installed.

It’s a difference: downloading the kar file just makes the addons available instantly, otherwise they have to be downloaded during installation:

For the ones that loved the offline distro (like myself): There is an easy way to get it back! Just additionally download the file openhab-addons-2.0.0-SNAPSHOT.kar and place it in your local addons/ folder - this will immediately make all add-ons available offline and you can safely deactivate the online repo access (in addons.cfg or through the Paper UI). You can even do the same now with the legacy add-ons (which were only available online before) - simply download the openhab-addons-legacy-2.0.0-SNAPSHOT.kar and put it into the addons/ folder.

Manually installing an addon by putting them into the /addons folder makes addons available which are not yet part of the openHAB distro (=are not showing up in PaperUI), like @job already mentioned.

I do not fully grasp the concept here. Maybe you can help me with an example.
The goal is to make mapdb plugin available. May target machine has no internet connection so I downloaded the kar file and put it in the addon folder.
What additional steps do I have to take to make it available and how do I get to show it in paper-ui?
It always shows as “not installed”.

That is exactly the usecase for the addons .kar file.
But when I remember correctly from using the old “offline” distribution a long time ago, it has nothing to do with the addons showing up in a GUI.
They should show up regardless of putting the kar file in the addons folder or not.
Make sure you have the correct addons folder (there are differences for the file locations) and make sure you are looking at the correct tab (you need to go to the “Persistence” tab).
Also make sure you don’t have the option “Access Remote Repository” set.