How to identify a problem? Tons of Logfile-Entries

Hey,

I moved from knx1 to knx2 binding… and after some work i finished building the knx.things file.

But not i got tons of error-messages (maybe 50 per minute…) in my openhab.log and I am not sure how to identify the thing(s) producing the errors…

2018-11-13 12:09:46.386 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.lang.IllegalArgumentException: Value must be between 0 and 100
	at org.eclipse.smarthome.core.library.types.PercentType.validateValue(PercentType.java:58) ~[?:?]
	at org.eclipse.smarthome.core.library.types.PercentType.<init>(PercentType.java:53) ~[?:?]
	at org.openhab.binding.knx.internal.dpt.KNXCoreTypeMapper.toType(KNXCoreTypeMapper.java:811) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.processDataReceived(DeviceThingHandler.java:288) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.lambda$8(DeviceThingHandler.java:274) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.withKNXType(DeviceThingHandler.java:121) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.onGroupWrite(DeviceThingHandler.java:269) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient$1.lambda$0(AbstractKNXClient.java:107) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.lambda$8(AbstractKNXClient.java:254) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Thre

or

2018-11-13 12:09:46.311 [WARN ] [calimero.mgmt.MC (MYIPGOESHERE):3671] - problem reading property (response 43 d6 00 09 00 01)
tuwien.auto.calimero.KNXRemoteException: property access OI 0 PID 9 failed/forbidden
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.extractPropertyElements(ManagementClientImpl.java:986) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.lambda$readProperty$0(ManagementClientImpl.java:570) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.waitForResponses(ManagementClientImpl.java:905) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.readProperty(ManagementClientImpl.java:568) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.readProperty(ManagementClientImpl.java:535) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.lambda$2(DeviceInfoClientImpl.java:107) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.readFromManagementClient(DeviceInfoClientImpl.java:56) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.readDeviceProperties(DeviceInfoClientImpl.java:105) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInspector.readDeviceProperties(DeviceInspector.java:111) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInspector.readDeviceInfo(DeviceInspector.java:88) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.describeDevice(AbstractKNXThingHandler.java:89) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.lambda$0(AbstractKNXThingHandler.java:153) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]

Any Idea for me?
Thanks,
Patrick

You have one or more Dimmer Items or Rollershutter Items that are being commanded to or receiving an update to a value that isn’t an integer between 0 and 100, the only values supported by these Items. Try changing your Dimmer and Rollershutter Items to Number Items until the errors go away. Then look more closely into what is updating that Item to see why it is sending invalid data for that Item type.

The seconds error is KNX specific and I can’t help with that.

Hey,
I used much much time to try to find the device with the problem… I failed.

I have got about 1.000 Channels inside my knx.things … And whatever I do, the error does not disappear.
I even tried to upgrade the logging to debug… but the error-messages still do not tell me anything.

First of all I thought my rgbw-4-channel-dimmers use 255 instead of 100 (rgb instead of percent…) but this is correct.

Anyone any idea how to identify the channel(s) producing this errors? It seems it is produced by many channels, because of the number of error-messages.

2018-11-14 23:02:12.755 [WARN ] [calimero.mgmt.MC 195.114.10.101:3671] - problem reading property (response 43 d6 00 4e 00 01)
tuwien.auto.calimero.KNXRemoteException: property access OI 0 PID 78 failed/forbidden
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.extractPropertyElements(ManagementClientImpl.java:986) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.lambda$readProperty$0(ManagementClientImpl.java:570) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.waitForResponses(ManagementClientImpl.java:905) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.readProperty(ManagementClientImpl.java:568) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementClientImpl.readProperty(ManagementClientImpl.java:535) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.lambda$2(DeviceInfoClientImpl.java:107) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.readFromManagementClient(DeviceInfoClientImpl.java:56) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.readDeviceProperties(DeviceInfoClientImpl.java:105) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInspector.readDeviceProperties(DeviceInspector.java:108) ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInspector.readDeviceInfo(DeviceInspector.java:88) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.describeDevice(AbstractKNXThingHandler.java:89) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.lambda$0(AbstractKNXThingHandler.java:153) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?] 

Thanks,
Patrick

Are you using fetch=true on your KNX Things?
try to set it to false to see if this WARN goes away (it’s only a warning that it can’t read some properties…most likely due to the fetch and the actuator does not support this function)

Check: KNX Binding 2.3

post your KNX.things and KNX.items to be checked

Hey Angelos,

thanks… :slight_smile:
knx.items.txt (118.8 KB)
KNX.things.txt (100.5 KB)

Errors:

2018-11-21 14:31:09.670 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.lang.IllegalArgumentException: Value must be between 0 and 100
	at org.eclipse.smarthome.core.library.types.PercentType.validateValue(PercentType.java:58) ~[?:?]
	at org.eclipse.smarthome.core.library.types.PercentType.<init>(PercentType.java:53) ~[?:?]
	at org.openhab.binding.knx.internal.dpt.KNXCoreTypeMapper.toType(KNXCoreTypeMapper.java:811) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.processDataReceived(DeviceThingHandler.java:288) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.lambda$8(DeviceThingHandler.java:274) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.withKNXType(DeviceThingHandler.java:121) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.onGroupWrite(DeviceThingHandler.java:269) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient$1.lambda$0(AbstractKNXClient.java:107) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.lambda$8(AbstractKNXClient.java:254) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]
2018-11-21 14:31:09.705 [DEBUG] [.internal.handler.DeviceThingHandler] - Thing 'knx:device:KNXROUTER:heizungsaktor_1_2_40' received a Group Write telegram from '1.2.40' for destination '4/0/60'
2018-11-21 14:31:09.705 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.lang.IllegalArgumentException: Value must be between 0 and 100
	at org.eclipse.smarthome.core.library.types.PercentType.validateValue(PercentType.java:58) ~[?:?]
	at org.eclipse.smarthome.core.library.types.PercentType.<init>(PercentType.java:53) ~[?:?]
	at org.openhab.binding.knx.internal.dpt.KNXCoreTypeMapper.toType(KNXCoreTypeMapper.java:811) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.processDataReceived(DeviceThingHandler.java:288) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.lambda$8(DeviceThingHandler.java:274) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.withKNXType(DeviceThingHandler.java:121) ~[?:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.onGroupWrite(DeviceThingHandler.java:269) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient$1.lambda$0(AbstractKNXClient.java:107) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.lambda$8(AbstractKNXClient.java:254) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?] 

Thanks a lot :slight_smile:

Very, very nice KNX setup! I am jealous :smiley:

So… now for your Warning: According to what I saw, these are the configs associated with GA 4/0/60

knx.things (last line in snip below)

Thing device heizungsaktor_1_2_40 [
		address="1.2.40",
		fetch=true,
		pingInterval=300,
		readInterval=3600
	] {
		Type contact : status 	 							"Heizungsaktor 1.2.40 // Status"						[ ga="4/3/0+<4/3/0" ]
		Type contact : error 	 							"Heizungsaktor 1.2.40 // Störung"						[ ga="4/3/1+<4/3/1" ]

		Type number  : channel_A_sollwert  					"108 // Wohnen // Sollwert Temperatur in °C"			[ ga="9.001:4/0/63+<4/0/65" ]
		Type number  : channel_A_stellwert  				"108 // Wohnen // Stellwert Temperatur in %"			[ ga="5.004:4/0/60" ]
...

knx.items

/* Raum 108 - Wohnszimmer + Arbeitszimmer */
Number Heizung_Stellwert_108 		    "108 // EG Wohnen // Stellwert in %" 		        { channel="knx:device:KNXROUTER:heizungsaktor_1_2_40:channel_A_stellwert" }
/* Raum 109 Erdgeschoss - Küche */
Number Heizung_Stellwert_109 		    "109 // EG Küche // Stellwert in %" 		        { channel="knx:device:KNXROUTER:heizungsaktor_1_2_40:channel_A_stellwert" }

2 Items linked to the same Channel UID? That’s fine and it will work… but do you want this or it’s a typo?

Try changing the DTP from 5.004 (PercentType 0-255) to 5.001 (PercentType 0-100) on the Channel to see if this solves it… most likely not… I will continue looking to see if I can identify any other potential problem

By the way: is this the only warning that you get in your logs?

we may have to enable TRACE on the calimero library also to make sure that we are capturing the correct info linked to the warning.

The first WARN is associated to the same GA?

Wait… I am not sure that this is linked to your KNX setup…this is a warning from org.eclipse.smarthome.core.internal.common.WrappedScheduledExecutorService so this may be something else.

Is this WARN always happening in relation to KNX?

@Udo_Hartmann : any ideas?

@Dim I don’t know this exception, but i guess, there is a rule with a timer involved… :wink:

@ByteBandito As a first point, you have at least one double definition in KNX.things, device dimmaktor_1_2_25

Do you have a rule which uses the item Heizung_Stellwert_108?

by the way @ByteBandito : I would disable readInterval=3600 if I was you
You have alooot of GAs and if you poll every 3600 secs = 1 h all of them, you may saturate the KNX Bus at that moment

You don’t really need readInterval in most of the cases (set to 0)

Also, you use fetch=true : not really needed… This will also create a small “storm” when the binding starts up.

Also: ping is also too fast (300 secs = 5 mins). Not really needed to ping faster than 10 mins (even this is fast)

Yes, totally forgot this…

Please avoid readInterval. This is only to force a read request for each GA which is readable per openHAB configuration. In most cases, there is no need for frequent read requests, as the most knx devices provide either send by change or send frequently (of both methods), this option is only for devices which must be triggered by a read request.

fetch is a nice option, to get additional information about the device. I don’t know if this fetch will de done once (when knx2 binding starts up) or frequently. I see some errors when using this option, so I disabled this for the most devices.

pinginterval is not reliable (i.e. the device is shown as OFFLINE although each command is executed correctly).

1 Like

@Dim Thanks :slight_smile:

  • I changed the 4/0/60 to 5.001 (and the other similar devices also).
  • heizungsaktor_1_240 is no typo. But I dont know why i did this… cant remember :slight_smile:
  • I enabled trace to calimero and knx. And right now i am a bit flashed… tons of information ;-)… I will try to collect errors / warnings beeing showed.
  • I changed pinginterval to 900, which is 15 minutes and set readinterval to 0. We’ll see if it changes anything… The peaks of my knx-bus are at about 45% utilization.
  • I kept Fetch. If i disable it, the knx-actors are shown offline in my paperui, which may not be a huge problem, but it helps me finding problems to have a look there.

@Udo_Hartmann
Nop, no rules for heizung_stellwert_108 (and no rules for heizing at all…).
But what I do have is a persistence for influxdb:

Strategies {
    everyMinute : "0 * * * * ?"
    everyHour   : "0 0 * * * ?"
    everyDay    : "0 0 0 * * ?"
}

Items {
    *                         : strategy = everyChange, everyMinute, restoreOnStartup
}

This should apply to everything, right?

@Both of you:
Big thanks for helping me with that!
If you are some time near frankfurt/germany i will be happy to share a good glas of wine or something else with you. Thanks!

Patrick

1 Like

That’s strange… I have fetch=false for all Things and I still have them Online in PaperUI.
I think that the pinginterval is the one that affects the Online status but I am not 100% sure.

Yes, maybe you did not get a correct value for the channel and openHAB tries to restore a NULL value.

As this is a mass of items, I recommend not to use restoreOnStartup. Please reduce persistence to those items which need to be persisted (this will also reduce size of data store in influxdb :wink: )
Best practice for restoreOnStartup is only to restore those items which can’t be restored through the binding itself.
As knx will request the status for each readable GA, there is absolutely no need for restoreOnStartup.

1 Like

Also, you will get better performance if you go with MapDB for restoreOnStartup (since MapDB only stores the value of the last state)

Use InfluxDB for storing historical data that you can graph and in parallel, setup a simple MapDB persistence service for whatever you want to restore.

I use 2 groups for this:
gMapDB
gInfluxDB

If I want to restore + graph = I make the Item (or other Groups) member of both Groups.

Then, you use the Group names in your persistence configs:
for influxdb.persist

Items {
    // persist all members of gInfluxDB Group
    gInfluxDB* : strategy = everyChange, everyHour, everyDay
}

same story for mapdb.persist

Items {
    // persist all members of gMapDB Group
    gMapDB* : strategy = everyChange, restoreOnStartup
}

Small update: my logfiles grew within 2 hours to 45 MB :slight_smile:

I will have a closer look this evening.

with this kind:

2018-11-13 12:09:46.311 [WARN ] [calimero.mgmt.MC (MYIPGOESHERE):3671] - problem reading property (response 43 d6 00 09 00 01) tuwien.auto.calimero.KNXRemoteException: property access OI 0 PID 9 failed/forbidden

or this:

2018-11-13 12:09:46.386 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: java.lang.IllegalArgumentException: Value must be between 0 and 100

?

hopefully you have disabled TRACE logging on calimero and KNXv2 binding :slight_smile:

By the way: the first warn is due to the fetch. you should disable the fetch and the warn should go away and the Thing should stay online

Hey,

I think most problems disappeared… I have to watch some more :slight_smile:

Yet it did not minimize the persistance-usage… but thats the only thing left. I hope.

The only problems of the last 6 hours:

2018-11-22 15:06:20.994 [WARN ] [net/IP Tunneling 1xx.1xx.1x.101:3671] - response timeout waiting for confirmation
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->1.2.50 L_Data.req, system priority hop count 6 repeat, tpdu 81
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:244) ~[?:?]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:258) ~[?:?]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:178) ~[?:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:243) ~[?:?]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:351) ~[?:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:222) ~[?:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.sendDisconnect(TransportLayerImpl.java:612) ~[?:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.disconnectIndicate(TransportLayerImpl.java:600) ~[?:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.disconnect(TransportLayerImpl.java:342) ~[?:?]
	at tuwien.auto.calimero.mgmt.Destination.destroy(Destination.java:371) ~[?:?]
	at tuwien.auto.calimero.mgmt.Destination.close(Destination.java:383) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementProceduresImpl.isAddressOccupied(ManagementProceduresImpl.java:311) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.isReachable(AbstractKNXClient.java:338) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.pollDeviceStatus(AbstractKNXThingHandler.java:144) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.lambda$1(AbstractKNXThingHandler.java:184) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]
2018-11-22 15:06:20.998 [WARN ] [calimero.mgmt.TL 1xx.1xx.1x.101:3671] - disconnected not gracefully (timeout)
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->1.2.50 L_Data.req, system priority hop count 6 repeat, tpdu 81
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:244) ~[?:?]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:258) ~[?:?]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:178) ~[?:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:243) ~[?:?]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:351) ~[?:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:222) ~[?:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.sendDisconnect(TransportLayerImpl.java:612) ~[?:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.disconnectIndicate(TransportLayerImpl.java:600) ~[?:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.disconnect(TransportLayerImpl.java:342) ~[?:?]
	at tuwien.auto.calimero.mgmt.Destination.destroy(Destination.java:371) ~[?:?]
	at tuwien.auto.calimero.mgmt.Destination.close(Destination.java:383) ~[?:?]
	at tuwien.auto.calimero.mgmt.ManagementProceduresImpl.isAddressOccupied(ManagementProceduresImpl.java:311) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.isReachable(AbstractKNXClient.java:338) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.pollDeviceStatus(AbstractKNXThingHandler.java:144) ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.lambda$1(AbstractKNXThingHandler.java:184) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]




2018-11-22 20:05:47.575 [WARN ] [net/IP Tunneling 1xx.1xx.1x.101:3671] - response timeout waiting for confirmation
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->1.2.14 L_Data.req, system priority hop count 6 repeat, tpdu 81
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:244) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:258) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:178) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:243) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:351) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:222) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.sendDisconnect(TransportLayerImpl.java:612) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.handleConnected(TransportLayerImpl.java:528) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.access$400(TransportLayerImpl.java:87) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl$NLListener.indication(TransportLayerImpl.java:127) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.AbstractLink$LinkNotifier.lambda$frameReceived$1(AbstractLink.java:159) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.internal.EventListeners.fire(EventListeners.java:129) [236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.EventNotifier.fire(EventNotifier.java:164) [236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.EventNotifier.run(EventNotifier.java:101) [236:org.openhab.binding.knx:2.4.0.201811221124]
2018-11-22 20:05:47.576 [WARN ] [calimero.mgmt.TL 1xx.1xx.1x.101:3671] - disconnected not gracefully (timeout)
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->1.2.14 L_Data.req, system priority hop count 6 repeat, tpdu 81
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:244) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:258) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:178) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:243) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:351) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:222) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.sendDisconnect(TransportLayerImpl.java:612) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.handleConnected(TransportLayerImpl.java:528) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.access$400(TransportLayerImpl.java:87) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl$NLListener.indication(TransportLayerImpl.java:127) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.AbstractLink$LinkNotifier.lambda$frameReceived$1(AbstractLink.java:159) ~[236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.internal.EventListeners.fire(EventListeners.java:129) [236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.EventNotifier.fire(EventNotifier.java:164) [236:org.openhab.binding.knx:2.4.0.201811221124]
	at tuwien.auto.calimero.link.EventNotifier.run(EventNotifier.java:101) [236:org.openhab.binding.knx:2.4.0.201811221124]

These are timeouts that happen between your KNX binding and the KNX devices…
Can you check if the KNX Bus is overloaded at these moments in time?

Also: I would try to set the localSourceAddr="x.y.z" to something that the KNXnet/IP Tunneling interface provides for its clients.
Look into the configuration of your Tunneling interface to see which IAs it provides and use one of them in the binding config to see if things improve.

Hey,

it seems the bus is not overloaded, but openhab is:

1773 openhab 20 0 11,786g 878644 20720 S 216,0 2,7 1:45.96 java

216% cpu usage for java / openhab.

After a reboot it seems to work normal again for maybe one day.

sorry to say, but it seems that there is something seriously wrong with your OH2 installation…
you need to go into debug mode and identify the issues (most likely caused by mis-configurations)

I have my system controlling 10+ bindings (KNX included) with uptime >1 month (due to frequent upgrades) and the cpu is: