How to install a 2.X binding manually? (In this case KNX)

Your email address is bouncing mail?

Mine normally not (gmail account) ist Christophers? Had you sent it already? Haven’t seen anything till now,
if not working try nico@bille.de should also work. Thanks.

@kgoderis
Could you send me the compiled KNX Bilding too? My mail address is joerg.mar20@gmail.com. Thank you very much!

Could you sen me the compiled KNX binding too? I simply do not get the 1.9 to work and I would rather like to try the 2.0.
weggenmann.sebastian@gmail.com

Thank you
Sebastian

I think I know why it bounces or has problems: It’s a .jar-file. Outlook doesn’t wanted to let it save me but shows it’s there. Now I saved it on IOS Mail App to dropbox to have it. Now I’ll try it out!

It loads up and I can configure it. But log says “can’t connect”. Don’t know why ATM, hopefully I’ll get some time after work to take a deeper look.

In the latest 2.0 snapshots I can’t get the KNX you sent to work. But as there is the “new” one coming (https://github.com/openhab/openhab2-addons/pull/1438) I am wondering if there is an idea when it could be integrated in the snapshot builds? Is there any kind of ETA @kgoderis? Thanks very much!

@nibblerrick ETA… mmhhh… depends how urgently @Kai needs it for his own installation.

The stable .jar that I have does not work anymore on a recent snapshot due to a change in the ESH API and Thing lifecycle. So do not even bother trying that one out.

The one in the PR I am currently testing and improving, but that takes time as I want to test it in my own operational environment. It takes a lot of time to edit my configuration files (2500 Group Addresses, 2000+ Items) wrt the new syntax used in the PR. Bear with me is the only thing I can say, unless you want to set up the IDE yourself and compile and export the .jar from there.

Ok, no problem, I will migrate to OH2 then with the old KNX-binding first.
How big is your house with 2000+ items? Sounds not like a one-person-bungalow.
I will keep an eye on the PR and try to send a XSD for ETS4. If it works where should I send it @kgoderis?

@nibblerrick Karel dot Goderis at me dot com

@kgoderis i did try to establish a IDE with your repo in it -but got stuck in tons of dependencies and resulting errors.
Is there a good howto for setup the IDE and everything around openhab2?

Because i do like openhab a lot. But 2.0 is not usable for me as long as knx integration is that fuzzy in terms of usage and documentation.

I can also support test and documentation - i only have 100 ga in use.

@JoeRu In fact there is : https://github.com/eclipse/smarthome/blob/master/docs/documentation/development/ide.md
and here http://docs.openhab.org/developers/development/ide.html

@kgoderis, please would you be so kind and send me the compiled 2.0 binding. The 1.9 which is in OH2 produces loops for switched devices. My mail add is martin dot knopf at gmail dot com
Thanks!

At the moment there isn’t one, the old one @kgoderis sent isn’t usable anymore and a new one you have to build yourself at the moment if you want it (I haven’t built one…) so let’s hope it won’t take to long till it will be integrated. The problem with the loops I have, too, and it disconnects but however with the setting “autoReconnectPeriod=10” it runs so far OK for me.
Maybe that helps at the moment until the new binding gets ready for testing.

HI,

I am recently also trying out OPENHAB2 but I am having difficulties getting KNX2.0 installed. Could someone send me the latest JAR file?

mail= bert.strouwen@pandora.be

Regards,

Bert

Thanks for this hint but this settings works only for a few moments in my case. Switching over openhab works now but when I press a usual knx sensor for this light, openhab loops again.

HI @kgoderis,

Could you send me the latest jar as well? I am having the same difficulties as described above. Tried importing the source into Eclipse and export as jar file, but does not show up in karaf console.

mail=bert.strouwen@pandora.be

Thx,

Bert

Hello @kgoderis,

could you please send me the jar file too?

mail=oh2.amai@wp45.de

Thx,
A. Mai

I’m using openHAB 2 with KNX Binding 1.9 and I’ve got loops on my KNX bus: see Loops on KNX bus

I was hoping that this is fixed when I use the current build of KNX Binding 2.0. So I tried to build the JAR that everybody here is talking about. Without success.

What I did:

  1. I installed Eclipse as detailed in “Setting up an IDE for openHAB
  • I checked “openHAB Development” and “openHAB 2 Addons”
  1. Then I checkout your repo from https://github.com/kgoderis/openhab2 into a separate folder
  2. Then I switched to your knx-refactor branch
  3. Then I copied your org.openhab.binding.knx folder besides all the other OH2 addons I got with the IDE setup (git/…/addons/binding)
  4. Then I imported org.openhab.binding.knx as an existing project into eclipse --> no errors
  5. Then I changed the two “version” flags in your pom.xml from 2.0.0-SNAPSHOT to 2.1.0-SNAPSHOT (otherwise parent won’t be found)
  6. Then I added org.openhab.binding.knx to the pom.xml of the parent binding directory
  7. Then I called “mvn install” from “openhab-distro”
  • The resulting KAR file in “openhab-distro/distributions/openhab-addons/target” only contains the 1.10 version of the knx binding - no idea why. I was hoping to find your 2.0/2.1 binding here somewhere
  1. Then I called “mvn package” from the org.openhab.binding.knx folder --> a jar got build

  2. I copied the JAR to /usr/share/openhab2/addons (owner and group openhab)

  3. I set “binding = knx” instead of “binding = knx1” in my addons.cfg

  4. I restarted openhab

  5. Then I got this log output:

    21:46:40.304 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
    21:46:41.024 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
    21:46:41.907 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
    21:46:42.264 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
    21:46:42.403 [ERROR] [org.openhab.binding.knx ] - FrameworkEvent ERROR - org.openhab.binding.knx
    org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.knx [190]
    Unresolved requirement: Import-Package: gnu.io
    at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]

Okay, enough trial and error!

@kgoderis:
Could you please tell me what I REALLY have to do to build your KNX Binding 2.0 ???
Or could you set up a small git repo etc. which always contains the latest JAR you built (would be helpful for anybody here) ?
If none of the two, could you please send me your latest jar to stephanschuster at web de

Thank you.

@stephanschuster The build is ok, you need to install openhab-transport-serial in karaf

@kgoderis: Thank you for your quick response.

I’m new to all this, so please be patient with me. I installed openhab-transport-serial via feature:install openhab-transport-serial. Worked. Then it complained about “Unresolved requirement: Import-Package org.openhab.core.items”. So I did feature:install openhab-runtime-compat1x. Right? At least it worked. No errors on startup. However, I cannot switch my light anymore via HABpanel. Seems like the KNX binding is not installed. I was expecting PaperUI to list it under Addons/Bindings. It does not.

And in karaf it should probably also be listed. Right? It is not.

openhab> feature:list | grep knx
openhab-binding-knx1                      | 1.9.0            |          | Uninstalled | addons-2.0.0            | KNX Binding

Maybe a problem with the JAR name or its 2.1.0 version instead of 2.0.0?

[23:42:17] pi@pi:~$ ll /usr/share/openhab2/addons
total 816K
drwxr-xr-x 2 openhab openhab 4.0K Feb  6 23:14 ./
drwxr-xr-x 5 root    root    4.0K Jan 27 21:02 ../
-rw-r--r-- 1 openhab openhab 803K Feb  6 23:14 org.openhab.binding.knx-2.1.0-SNAPSHOT.jar
-rw-r--r-- 1 openhab openhab   70 Jan 22 21:40 README

My addons.cfg:

package = minimal
remote = true
binding = knx
ui = basic,paper,habpanel

Sorry for bothering you.