How to install modbus 2.9 on base system 2.5

I’m running OH2.5 on Synology. I have problems with modbus and want to try the latest modbus binding.
I download the .kar file [here]( from
From the openhab-addons-2.5.9\repository\org\openhab\addons\bundles I placed org.openhab.binding.modbus-2.5.9.jar file in /openHAB/addons/
I uninstalled modbus 2.5.0 binding with paperui.
I renamed the tmp and cache dirs to tmp_save and cache_save.
I restarted openhab and everything was working again but with paperui i didn’t see de modbus 2.9 binding with paperui.
What step do I need to do additionally?

Where are you looking in PaperUI? I don’t think you will see manually installed add-ons listed under add-ons. But I think you should see it when you scan for new devices in the inbox or try to create a new Thing manually.

Don’t use Modbus 2.5.9, a moments search shows people having trouble with it in this forum. A packaging issue.
Use 2.5.8 or a 2.5.10 snapshot.

I would expect the binding here.

. I only find the 2.5 version

Thanks I replaced it with snapshot 2.5.10. Now get it working

Do U have a link to the 2.5.10 addons package?

Found the latest, doesn’t help. I cannot install the modbus-binding on my Synology via web or manually:
[ERROR] [.core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-modbus': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-modbus; type=karaf.feature; version="[2.5.2,2.5.2]"; filter:="(&(osgi.identity=openhab-binding-modbus)(type=karaf.feature)(version>=2.5.2)(version<=2.5.2))" [caused by: Unable to resolve openhab-binding-modbus/2.5.2: missing requirement [openhab-binding-modbus/2.5.2] osgi.identity; osgi.identity=org.openhab.binding.modbus; type=osgi.bundle; version="[2.5.9,2.5.9]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.binding.modbus/2.5.9: missing requirement [org.openhab.binding.modbus/2.5.9] osgi.wiring.package; filter:="(" [caused by: Unable to resolve missing requirement [] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.commons.pool2)(version>=2.8.0)(!(version>=3.0.0)))"]]]

No, you haven’t

use 2.5.8 or a 2.5.10 snapshot

Thanks you for your help; on my Synology there is only the 2.5.2 available. Cannot upgrade there. Using the modbus 2.5.8/10 add-ons throws more missing requirement errors. Very strange, yesterday everything worked with 2.5.2 + 2.5.2-modbus + e3dc-modbus-binding.

Why do you think you need this anyway? You do better looking into your actual problem.