How to install Zigbee 2.4.0?

Tags: #<Tag:0x00007f433b7c0008>

When installing Zigbee from PaperUI, the Zigbee version is 2.3.0. I’m having problems with my zigbee devices - I’m able to discover them and add them as a thing but after that there’s no further communication between OpenHab (rpi) and the devices. I’m using the HUSBZB-1 dongle.

Seeing that there’s a 2.4.0 snapshot of this binding, I uninstalled Zigbee 2.3.0 via PaperUI and grabbed the zigbee 2.4.0 jar and the ember 2.4.0 jar and dropped them in /usr/share/openhab2/addons.

The log in karaf shows:

Unresolved requirement: Import-Package: com.zsmartsystems.zigbee

and the bundles list:

248 │ Installed │  80 │ 2.4.0.201809212104     │ ZigBee Binding
249 │ Installed │  80 │ 2.4.0.201809212104     │ ZigBee Ember Binding

After some troubleshooting and searching around, it looks like the binding doesn’t include all of the necessary resources.

I’ve added com.zsmartsystems.zigbee.dongle.ember-1.0.14.jar but its status is also “Installed”, not “Active”.

I’m not sure what I’m missing… I can’t seem to get this binding started…

Here are the names of all the bundles. You can install all of them, but only four are needed, based on the dongle you have. You’re missing com.zsmartsystems.zigbee. But the latest libraries are 1.1.1, so use those.

openhab> list -s |grep zig
271 │ Active   │  80 │ 1.1.1                  │ com.zsmartsystems.zigbee
274 │ Active   │  80 │ 1.1.1                  │ com.zsmartsystems.zigbee.dongle.xbee
275 │ Active   │  80 │ 1.1.1                  │ com.zsmartsystems.zigbee.dongle.ember
276 │ Active   │  80 │ 1.1.1                  │ com.zsmartsystems.zigbee.dongle.telegesis
278 │ Active   │  80 │ 1.1.1                  │ com.zsmartsystems.zigbee.dongle.cc2531
279 │ Active   │  80 │ 2.4.0.201809182206     │ org.openhab.binding.zigbee.xbee
280 │ Active   │  80 │ 2.4.0.201809182206     │ org.openhab.binding.zigbee
277 │ Active   │  80 │ 2.4.0.201809182206     │ org.openhab.binding.zigbee.telegesis
272 │ Active   │  80 │ 2.4.0.201809182206     │ org.openhab.binding.zigbee.cc2531
273 │ Active   │  80 │ 2.4.0.201809182206     │ org.openhab.binding.zigbee.ember

You could also use this script…