How to repair Openhab UI

Good morning,

Since I did upgrade to the newest OH version via sudo apt-get upgrad yesterday, I’m not able to login to the webpage. When I try to click on the lock symbol (bottom/left) nothing happens, the login webpage does not appear. After a while the webpage tries to load and load but does not show

The last thing I did yesterday, I made a configuration change to an ipcamera which shoudl refresh every 10 ms. This camera should show a picture in the OH overview webpage.

putty and command shell are working fine.

Is it possible that I can remove this thing configuration of the camera direct via command shell?
If this is not working, can I repair Openhab UI in a way to not loose my configuration?

Many thanks
Christian

Do you mean 10 miliseconds? That would keep the web service quite busy…

Disclaimer: I run OH completely from configuration files, so double check these files contain the right information.

Assuming you have no backup from before the upgrade (which would be the easiest way out), you can manually restore the previous IP-camera configuration from the JSON ‘database’ backups.
The JSON files are located in $OPENHAB/userdata/jsondb and there is also a backup subdirectory that holds backup versions of the files. You can copy the latest ...--org.openhab.core.items.Item.json file from before the change to replace the org.openhab.core.items.Item.json file, assuming your changes where made in the Item configuration.

WARNING:

  1. Make sure you do this while OpenHAB is not running!
  2. Make a copy of the existing org.openhab.core.items.Item.json file before replacing it.
1 Like

It should be possible to use the karaf console to disable the thing as long as the karaf console is responsive ( enough ).

  • login to karaf console: openhab-cli -p habopen console
  • search your thing: things list | grep ipcamera
  • disable the thing: things disable <thingUID>

In the last command replace <thingUID> with your thingUID that is returned by the command executed before.

Hi Wolfgang

When I try to disable the thing with the thingUID I get the message “an unexpected error occurred during execution”

things list | grep ipcamera shows:
ipcamera:onvif:5ad55ed58b (Type=Thing, Status=ONLINE, Label=Bibs Cam 1, Bridge=null)

the command I try: in openhab-cli is things disable 5ad55ed58b

what do I miss?

I think the thing id is the complete string: ipcamera:onvif:5ad55ed58b

thanks I was able to disable the thing now, but the webpage ist still unavailable

Have you tried to restart the openhab service?

Thank you, problem is fixed :slight_smile:
I was able now to login and reconfigure it.

So the page is now working perfect again.

Many thanks for your help.

1 Like