How to restart openHABian3 on rasberry PI

  • Platform information:
    • Hardware: Rasberry PI 4B 4GB 16 GB SD card
    • OS: Latest flash for rasberry 64bit you find here Releases · openhab/openhabian · GitHub
    • Java Runtime Environment: the one included in the flash mentioned above
    • openHAB version: 3.0.0
  • Issue of the topic: After installing the opencloud connector binding and using the correct uid and secred in the system stay mentioned as ofline. On this forum I found that you need to restart the openhab environment and that seems not to be possible so I have to do something wrong.
    I can connect via putty with the rasberry as explained here with the same login openhabian.

I try to do what is mentioned here to restart the openhab with those statements:
sudo openhab-cli stop
sudo openhab-cli start

but then I got the error message that he do not know the openhabian user as a sudo user.

I tried it also with sudo /bin/systemctl stop openhab.service and sudo /bin/systemctl start openhab.service with the same result.

So with what user and passwordt I’m able to do this with this set-up or how I can get this user as a sudo user?

What do you get if you do

grep sudo /etc/group


cat /etc/passwd |grep -v /bin/false |grep -v /usr/sbin/nologin

this one give:

So I supose I have to use this user? But what is then the password in the standard flash installation for this user?

This one gives this result:
openhabian:x:1001:115:openHABian,openHAB admin user:/home/openhabian:/bin/bash

login as user pi and use sudo to add user openhabian to sudo group.
Then you can continue as usual.
I think I saw one ( ? ) other user having the same problem.

And what password is then provided in the standard install of the flash for this user? The standard pasword from the rasberry is not working, and I tried also several standaard openhab openhabian paswords for this user and they are all not working. So in that way you are messed up.

Are there any error messages in /boot/first-boot.log ?

Did you read the note on the Releases page?

Note the 64 bit version is unsupported and untested. It's provided just as-is.


Not real errors found except this:

2020-12-17 22:27:44.974 [ERROR] [io.openhabcloud.internal.CloudClient] - Error connecting to the openHAB Cloud instance: not authorized
2020-12-18 07:37:17.395 [ERROR] [io.openhabcloud.internal.CloudClient] - Error connecting to the openHAB Cloud instance: {}

Please ignore the following error about deb-systemd-helper not finding those services.
(samba-ad-dc.service masked)
Created symlink /etc/systemd/system/ → /lib/systemd/system/nmbd.service.
Failed to preset unit: Unit file /etc/systemd/system/samba-ad-dc.service is masked.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on samba-ad-dc.service: No such file or directory

I found also this, but I believe that this is not related to the unix users:
2020-12-29_20:38:21_GMT [openHABian] Starting the openHABian initial setup.
2020-12-29_20:38:27_GMT [openHABian] Storing configuration… OK
2020-12-29_20:39:00_GMT [openHABian] Starting webserver with installation log… OK
2020-12-29_20:39:08_GMT [openHABian] Changing default username and password… SKIPPED
2020-12-29_20:39:14_GMT [openHABian] Setting up Ethernet connection… OK

Also the following was skipped:
2020-12-29_22:08:03_CET [openHABian] tailscale VPN installation… SKIPPED (no preauthkey defined)

That I missed. Mean this that for a 64 bit Rasberry there is currently no stable install?

This is skipped because of the way openhabian determines what OS is running and the 64bit os reports differently.

I running it on an 8gig pi because of kernel oops with zram :slight_smile:
Its not stable and its not supported and I running an experimental version and its not my production its still on OH2

The only error I got was when putting in auth key I used the wrong address and it loaded the whole http page into the authorised key file

What about reading the docs before install ?

This link I found a way to make the openhabian sudo user. Thanks for sharing that.

Well before I had my raspberry I was started with experimenting on OH2 on windows. I had read a lot of documentation at that time.
Then I received my raspberry and then the OH3 was the one to install, and I have not read everything again because I wanted to move forward. When the raspberry is 64bits I was expectig best taking that version for the installation too.
I had not the goal to attack anyone, just a question how I could get out a specific situation and I’m a bit surpriced to get then such an agressive answer in place. Lucky I got also usefull answers.

so you didn’t even click the link … maybe you should ?

Marc, I did and I have replied on that message that I found their usefull information and that I was gratefull for sharing that. I suppose that you have even not read that reply?
This was a reply on an other message then the link.

Happy 2021 to everybody.

So to answer the restart question now that you have sudo you can

sudo /bin/systemctl stop openhab.service
sudo /bin/systemctl start openhab.service
sudo /bin/systemctl restart openhab.service
sudo /bin/systemctl status openhab.service

Markus was just linking you to the document he wrote.