How to set up Eltako devices


I have here several Eltako devices like FUD14 and FSR14. According to documentation they are supported from openhab. Has any one an idea how to integrate them to openhab? I’ve tested all guidelines I have from other project like FHEM or wibutler, but none of them showed any result or reaction in openhab.

Openhab runs as openhabian on an raspberry pi3 with usb300 stick. The binding itself is installed an simple rocker switches are detected. So it seems more a question on how to bring the devices in a state that can be seen from openhab.

Thanks in advance.

If the binding is installed and it has detected Things, all you need to do now is create Items, link to the Channels on the Things and then you use the Items to interact with the devices over a sitemap, HABPanel, Rules, etc.

Several rocker switches are found, but not any of the FUD14 devices. I started the learning sequence as it is usually necessary to integrate in a home automation scenario, but this has no effect in openhab.

I also tried several settings of the FAM14 device because I found different guides in some projects. Unfortunately without success.

Then I would guess the binding doesn’t support those devices. You should file an issue to see if they can be added.

The main reason for me to give openhab another try is this:

The first 2 entries on the list of supported devices made my heard beat faster …

But unfortunately the section about setting it up is a bit vague.

I don’t know anything about this binding or the technology. But the docs indicate to you need either a USB300 or an EnoceanPi.

If you have the USB300 you just need to open the inbox in PaperUI and it will show up. If you have the EnoceanPi you need to manually create the Thing. Please the + in the inbox and follow the prompts.

Once the Thing representing the controller is found it will automatically discover the Enocean devices, adding a Thing for each device to the inbox automatically.

I come back to my first message. Openhabian is installed on a raspberry pi with an USB300 stick. After activating the enocean binding the stick appears in the inbox -> perfect

Pressing a rocker switch on the wall -> the switch appears in the inbox. But this is the switch that send a telegram, not the actor that controls the light.

Nothing else appears in the inbox. So my impression is that there is a small information missing in the docu.

Arno, the classical Eltako-Devices need a “teach-in” process. Just search for “FUD14” in the binding docu. They don’t work via discovery.
You have to follow the section “Pairing/Actuators” in the binding doc.

In short:

  1. List item define your FUD14 as a thing “centralCommand” (see example in docs)
  2. create a “virtual rocker” and connect that to the pairing-channel
  3. set your FUD14 to learn
  4. toggle the virtual rocker
  5. unset learn-mode and remove virtual rocker from item-definition

After these steps you should be able to control the actuator from OH


Markus, thank you very much. Now I’m getting closer.

I followed the steps, but pairing doesn’t still not work. Docu tells something about a “teach-in” channel. You named it pairing-channel. Is that something special? My thing only has a dimmer and a switch channel. Is that the same?

Hi @Arno,

you find the teach in channel when you click on the “More” button under channels. As you only need it once, I hide it normally.

Best regards

Hi Daniel,

thank you very much. Meanwhile I found the channel and it works. At least I could teach in, but it was not possible to do anything with the thing.

After several approaches I did the following:

  1. Start “ID erkennen” in PCT14
  2. Assign the found ID to my FUD14
  3. Change the type to “32 Dimmwert von GFVS / Drehtaster”. Without this step the actor’s led is blinking when I switch something in openhab, but no light is switch on/off.

I found this type information, because I have also a wibutler. And they use this type, too. Other types do not work here.

At last I had some strange problem. The enoceanID is automatically provided from the bridge (?). This works for 4 of my actors. The fifth always got the same address as the first one. After I changed it manually to 5 the teach in worked.


HI @Arno,

thanks for the hints. Strange :thinking: the teachin command for the dimmer should send exactly this parameter “32 Dimmwert von GFVS”. I will have a look, what is going wrong here. I will also look at the second point. Do you have defined some EnOcean thing with text files?

Best regards

Hi Daniel,

meanwhile I restarted my configuration and used an second USB300 with an external antenna. I could not reproduce the failure. So don’t spend too much time on that problem :wink:
The first issue still occurs.