How to setup gmail smtp config for personal openHAB cloud instance?

I can’t find any documentation regarding setting up mailer. For example “Forgot your password?” thing is not setting any email.

"mailer": { "host" : "smtp.gmail.com", "port": 465, "secureConnection": true, "user": "contact@robeacon.com", "password": "password", "from": "robeacon Cloud <contact@robeacon.com>" },

Am I doing anything wrong?

Sorry but how do you expect any one of us to help you?
You gave no information what openHAB Version you use, no information about what binding you are writing, no information what documentation you are looking for.
I am so confused about this topic, is this about owncloud? If so, you just posted in the wrong community, I will show you the way :slight_smile: owncloud community

If you need/want help, please provide the information needed to help you :smiley:

Ok. Let me give a more detailed explanation of my problem. I have my own openHAB cloud instance running on an amazon server. I followed the guide from here. The problem I have is that when a new account is registered no email is sent for account confirmation and when the “Forgot your password?” option is used, no email to reset the password is sent.

How can I fix this?

Any ideas?

Did you ever try to use the TLS Port 587 instead of SSL 465?

Yes, I did but no luck. I will give it a try one more time maybe I did something wrong.

Also to clarify something, your E-Mail contact@robeacon.com is setup with Gmail so you can send and receive Mails via Gmail with this custom domain?

Yes, I receive and I can send emails

After I did some more digging I managed to solve the problem. All I had to do was to to turn on access to less secure apps in the gmail security tab. Here you have an explanation how to do it in case someone will encounter this problem too in the future.