How to setup rrd4j persistance within openHAB 2.5.9

Hello again,

bevor I have made my update from openHAB 2.1 to 2.5.9 I had an rrd4j database for e.g. logged temperatures. Now, i would like to have this feature again and I think it is still there … anywhere inside.

I still have my (old) rrd4j.persist file ind the related folder

Strategies {
    everyMinute : "0 * * * * ?"
    everyHour : "0 0 * * * ?"
    everyDay : "0 0 0 * * ?"

Items {
    onewiretemp1Value                   : strategy = everyMinute, restoreOnStartup
    onewiretemp2Value                   : strategy = everyMinute, restoreOnStartup

    HueSensTemperatur_1                 : strategy = everyMinute, restoreOnStartup
    HueSensTemperatur_2                 : strategy = everyMinute, restoreOnStartup
    HueSensTemperatur_Outdoor1          : strategy = everyMinute, restoreOnStartup

    HueSensIlluminace_1                 : strategy = everyMinute, restoreOnStartup
    HueSensIlluminace_2                 : strategy = everyMinute, restoreOnStartup
    HueSensIlluminace_Outdoor1          : strategy = everyMinute, restoreOnStartup

    HueSensMotionBatteryLevel           : strategy = everyDate, restoreOnStartup
    HueSensMotionBatteryLeve2           : strategy = everyDate, restoreOnStartup
    HueSensMotionBatteryLevel_Outdoor1  : strategy = everyDate, restoreOnStartup

… and the used items are present.

Could someone tell me the steps that I have to do to make rrd4j working again … and please in a “simple” manner ?

Thanks and best regards

That is a HUGE jump. Look at the major version Release Notes for Breaking Changes, especially 2.5.0.

I know there were massive changes just between 2.4 & 2.5.

Changes relating the a persistence service? Especially for rrd4j?

The only problem I notice in your .persist file is the missing everyMinute strategy for the last couple of items. Did that work before?
What is not working?
Are you trying the keep the history ( by using the .rrd from the updated installation)? Didyoumove those files? Are the access rigths correct?
Do you have more then one persistence service installed? Which is the default?

Thanks for your posting. The truth is, that I didn’t install any service for persiting data because I wasn’t able to find a binding or anything like this. That is the reason, why I ask for a setup (step-by-step tutorial or something similar).

Relate to your question “did that work befor”… yes in the former version, it seams to work, but the last 3 lines where add a feq hours ago and I detect there the mistake about the strategy your talked about.
“What is not working?” … the storage of Data. Wenn I look at “http://openhab:8080/rest/persistence” it looks quite empty. Means at “Rohdaten” (I Think “Rawdata”) I only the some brackets … [ ]

The update to version 2.5.9 was a complete new installation on a new sdcard.

Thanks for helping

Installing rd4j via PaperUI shouldbe straigth forward.
On PaperUI select Add-ons on the side menu, then Persistence on the on thetop menu, thatwillpresent youtheinstallable services. Move to rrd4j andclick the"Install".
Since you have already the rrd4j.persist file theservice should start immidiatly.
Give it some time and then you can use the REST API to fetch the stored data.

Your description is the way that I would expect … but … on the Add-ons-Side there are only “Bindings”, “Misc” and “Voice” but inside of all tree menu topics ther is no persistence option/selection available. Do I have to unlock this somewhere?

Can’t really say. I’m on Release Build.

If you are on the same version, I’d restart, check the logs and if that doesn’t give a clue I’d restart from scratch.

I updated to veriosn 2.5.10-1 … but … nothing changed …

Is there a way to hide some Add-ons or to I have to unlock them in the system-seetings?

Not to my (present) knowledge!

Have look Here

“Simple Mode” has a habit of hiding stuff, don’t know if that applies here.

Thanks to all. I had modified my /etc/openhab2/services/addons.cfg, were I add the following line


Formerly there was nothing only comments. After restarting openHAB with

sudo systemctl stop openhab2
sudo systemctl start openhab2

I could select the rrd4j-Add-On.


I’ll try remember that one! Sorry for not knowing!

@opus: Don’t be to so hard to yourself :wink: You have send me a link to a thread that solves my problem :ok_hand:

Thanks and best regards

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.