How to upgrade Zwave-Binding to latest Snapshot?

I am using the 2.0 Release Version (OH2 Core and Offline Addon package on Windows).
I would like to use the most recent addon package from the 2.1.0 snapshot. How can I get it to run? Just replacing the big .kar-File in the addon folder seemed to change nothing…any ideas? Thanks for your help!

Delete the zwave binding, download the snapshot, place it in addons directory.
You may need to perform these steps in addition to that:

What do you mean exactly when you say “Delete the zwave binding”? Delete the KAR-File in the Add-On-Directory?

Sorry, I was unclear: uninstall the binding through PaperUI or HABmin.

Ok, thank you for this detail. Do I also need to do a restart of OH2 in this case?

That may be needed, too.

Hmmm, after a restart of OH2 today the old Zwave-Bindung (2.0.0) is back. How do I make the upgrade to the 2.1 Snapshot to last even after a restart?

Do you have it in conf/services/addons.cfg on the binding = line? If so that may be causing your problem.

No, the binding = line in addons.cfg is absolutely empty.

Then check


for any “zwave” entries.

yes, here was “,zwave” in the binding = line…
I removed it and then no Zwave-Binding at all was installed. I then installed the 2.1.0 Snapshot Zwave Binding via Paper UI, the result: The 2.1.0 binding works, shows as installed but PaperUI recreates the entry “,zwave” in the binding = line. So after next restart I meet again the old 2.0.0 binding. This more than odd. Sorry, but how many undocumented config files are messing around in OH2 and how is the interaction between UI and files? This is close to unusable.

So my question remains: How to remain with the Snapshot binding after a restart?

Wrong decision: drop the downloaded jar into your addons folder (see second post).

You are trying to make something work which is “non standard”.
If you want to use snapshot bindings you should use the snapshot release of openHAB.
Then there are no problems with using snapshot bindings.

and even more weird: After a restart the 2.1.0 Snapshot binding also ist not even available to select for installation in Paper UI. I have to manually delete the big Kar-File in the Addon-Directory and then copy it back in again. After that the 2.1.0-Bindings show up in Paper UI Addons section. I then can install it but all this will not survive a restart of OH2.
I always have to a) manually tweak the /userdata/etc/org.openhab.addons.cfg and b) move the big Kar-File in the Addon-Directory away and back after each restart.
Is there something I am doing wrong or is OH2 really still that unusable? :frowning:

I tried to use the snapshot release but with the snapshot last weekend the system did not find my sitemaps anymore although they were still placed unchanged in the correct directories, see my still unanswered post:

So I decided to try the 2.0 release version with just the latest Zwave binding. In OH1 I always used the latest Zwave bindings with the stable core version. Apparently this is not poosible anymore with OH2? This is odd, as you need the new binding version for new devices and at the moment also to use all functions of Zwave+ devices.

1 Like

Sure it is possible (again, see the second post).
But you have to tweak the system a bit to make it work … [quote=“vossivossi, post:14, topic:23268”]
see my still unanswered post:

I guess you got no answers because there are no answers … and nobody else encountered this problem as far as I know.

Thanks for your help, but when I am the only one then I have made something wrong when upgrading from release version to Snapshot? I follwed the only officially available instruction as posted here:

The result is that no sitemap is found although I changed NOTHING to my sitemap directories.

So although I tried multiple combinations, followed all recommendations here, asked all the experts and spent many hours there seems to be no way (at least with a windows platform) to have OH2 running stable (also after a system restart) with the latest Zwave Snapshot. And I am not talking about the experimental security Zwave branch, but the 2.1.0 Snapshot.

The problem with this approach (stable core and zwave snapshot): occasionally there are changes in the code for the ESH or openHAB2 core which are a prerequisite for a working zwave snapshot binding. So without updating the runtime you can not benefit from the changes in the snapshot binding.

I don’t think you did something wrong: I’m using the manual setup on Linux which is almost identical to the manual setup on Windows and it works all the time (doing upgrades almost weekly).

I have the same problem with no sitemaps. There are few others having the same problem so this is some soft of bug.

In the end it was a stricter syntax check for the sitemap files which prevented my old sitemap from loading. Try to start with just a new (nearly empty) dummy sitemap to see if this works. If it does try to rebuild the old sitemap until you catch the mistake.

1 Like

ok, thanks. this was my thinking but as it worked before i refrain of doing it…