How to use command=configuration?

I have two Monoprice Z-Wave Curtain Module, Vision Security ID d03 Type 200d. I can command open/close, but I am unable to set the durations via HABMin, so trying to set via the configuration command-class. I’ve tried getting this to work on a light switch in the past, but had no luck, so I just manually set everything in HABmin.

How does the configuration class work?

I’ve tried Items:

Dimmer Curtain_1_Conf { zwave=“50:command=CONFIGURATION, parameter=UP” }
Dimmer Curtain_2_Conf { zwave=“50:command=CONFIGURATION, parameter=DOWN” }
Dimmer Curtain_3_Conf { zwave=“50:command=CONFIGURATION, parameter=STOP” }

And items (not sure what the actual parameters IDs would be):
Dimmer Curtain_1_Conf { zwave=“50:command=CONFIGURATION, parameter=0” }
Dimmer Curtain_2_Conf { zwave=“50:command=CONFIGURATION, parameter=1” }
Dimmer Curtain_3_Conf { zwave=“50:command=CONFIGURATION, parameter=2” }

These don’t work via rule, or sitemap with:
Switch item=Curtain_1_Conf mappings=[10=“10”]
Switch item=Curtain_2_Conf mappings=[10=“10”]
Switch item=Curtain_3_Conf mappings=[10=“10”]

I’ve also tried a few different item types. What am I doing wrong?Months ago, I also tried to set configuration data on my Cooper light switches with no success:

Switch item=Dimmer_Hall_Panic label=“Set param0” mappings=[0=“0”, 1=“1”, 2=“2”, 3=“3”]
Switch item=Dimmer_Hall_Panic2 label=“Set param1” mappings=[0=“0”, 1=“1”, 2=“2”, 3=“3”]

Switch Dimmer_Hall_Panic { zwave=“6:command=CONFIGURATION, parameter=0” }
Switch Dimmer_Hall_Panic2 { zwave=“6:command=CONFIGURATION, parameter=1” }

The parameters are the parameter numbers from the user manual - it’s a number from 1 to 255.

Try looking in the log to see if there’s any errors/warnings - it might be that the dimmer won’t map correctly or something?

parameter number is value, not ID of config to set?

No - the parameter number is the ID of the parameter. It’s a number from 1 to 255 as per you device manual.

Parameter names are UP, STOP, and DOWN. Possible values to set are between 1-255 seconds. The manual doesn’t list the parameter IDs.

I switched to a different 1.9.0 binding and it appears to be “working” now…

For setting the three values, 10 seconds or 60 seconds:
Dimmer Curtain_1_Conf { zwave=“50:command=CONFIGURATION, parameter=1” }
Dimmer Curtain_2_Conf { zwave=“50:command=CONFIGURATION, parameter=2” }
Dimmer Curtain_3_Conf { zwave=“50:command=CONFIGURATION, parameter=3” }

Switch item=Curtain_1_Conf mappings=[10=“10”, 60=“60”]
Switch item=Curtain_2_Conf mappings=[10=“10”, 60=“60”]
Switch item=Curtain_3_Conf mappings=[10=“10”, 60=“60”]

Now what I find odd - with the new zbind binding file, I can set the properties in HABmin, but when using the config command, I can only go up to a value of “99”. HABmin allows me to exceed 99. Entering “240” in HABmin also gets me a final value of -16. Signed integers? It still runs for 240-seconds in the module.

It would be quite strange if it didn’t provide the parameter ids - I’ve never seen a manual that didn’t provide this (if it lists the parameters, it always provides this sort of information).

Can you provide a link to the manual, or the database?

Well, you’re using a dimmer, so it only allows valued from 0 to 99. As I said earlier, have you looked in the logs to see if there’s any error listed?

It’s fine - it works now. Had to find yet another zwave binding jar that is compatible with both the curtain module and my deadbolt.

Hi @chris

i want items file entry for configuration of any parameter of any device with some value.
so what should be items file entry for this kind of thing…?
the example provided above

Dimmer Curtain_1_Conf { zwave=“50:command=CONFIGURATION, parameter=0” }

i can’t see the parameter value…

Please tell correct entry…


What you have looks correct to me (although parameter 0 is probably invalid I think, but it depends on the device).

What do you mean by value?

Hi @chris,

i am trying to set configuration for aeotec energy meter .
my items entry is as below:

Number METER_G1_value {zwave=“6:0:command=CONFIGURATION,parameter=101”}

But i am getting an error:

2016-11-16 19:44:18.263 [WARN ] [.c.ZWaveConfigurationConverter] - NODE 6: No converter found for item = METER_RC(NumberItem), endpoint = 0, ignoring event.

what can be the correct entry…?

I want to reset energy value (or any parameter value ) to zero ,
How can i do this in openhab…?
Is there any command class for doing this…?


The error doesn’t seem to be related. Your item is METER_G1_value, while the error says METER_RC.

The METER command class normally supports the reset command for this purpose which I think is defined in the Wiki. Some devices don’t support this, but it’s rare, so I would assume you can use this ok.

Hi @chris,

i got an example items entry from google mailing list:

Switch Living_EnergyReset “Living Lamp”
(EnergyMonthlyReset) {
zwave=“4:command=METER,meter_reset=true”, autoupdate=“false” }

But further discussion on mailing list says, it requires support in xml file
i am attaching my xml file . Can you check into my xml file wheather METER_RESET supported or not…?

.node6.xml (13.3 KB)

I don’t really know what discussion you are referring to, but there should not be anything needed in the XML. The XML is generated by OH - you generally can’t just modify this file.

You don’t say what the problem is? What actually happens?

  1. I am referring to discussion regarding “Reset energy consumption value (E_kWh) to zero”.

Anyway , i got it working with above items file entry.
i successfully resetted the E_kWh value to zero.

Thanks for the help