How we can control own created new device of Z-wave on openhab

Hi, I designed the prototype using ZM5202 (Sigma designs) in which created 9 endpoints for on/off and for dimming and using meter command classes. So, how will I test this on openhab. So, I am very confused now all channels that I created in the firmware, how to link on openhab

Same problem here with Z-UNO,

I have installed Home Assistant in parallel to OpenHab.
In Home Assistant

  • include your own device
  • Setup mqtt for localhost
  • make rule at state change to publish.mqtt your own device

In OpenHab 2.4 (No need for mosquitto)

  • install embedded mqtt server(addons->misc)(Else use Mosquitto)
  • install mqtt Binding
  • create generic mqtt Thing(one device one Thing)
  • add chanels to thing

That’s IT

Sorry for my english, greatings from germany

Your case is different from mine. I briefly say in my case i.e I created 9 channels in firmware but when I add node on openhab firstly it is showing unknown z-wave device and my single node consists of 9 sub-nodes (3 binary and 6 multilevel). So how we get the device on openhab and node channel how to link with it.

@monikajha - you will need to add your device to Chris Jackson’s Zwave Database. The instructions for doing so are here including how to add endpoints to your new device. Once you update the database and submit a ticket, @chris will include it in an upcoming release of the Zwave binding, and your device will be published for use by others!

There is another way for testing without adding in database on openhab.

I’m not an expert on adding new devices tot he Zwave DB (all of mine were already in it), but I do think there is a way to do it locally (although you might have to set up the full OH build environment to do so).

For adding in database, Is it necessary z-wave device should be certified.?

No, it doesn’t seem so - you just need to make sure you define all the endpoints correctly.

Actually, I added the device manually in database and updated the PCB photo and manual but device is not added in database.

No, its the same case for me…

My device also is´nt in Database. My workaround is to add device in Homeassistant and than publish the device per mqtt to openhab.

When I adding node what it is showing.I share screenshot with it.

I dont know your development state. The way OH is doing device including (per Database) is’nt the way zwave is made for. Bevor hassle with it, i would prefere using Homeassistant or Zway. Then when your newly developt device become final, i would add it to Database.

Chris ist aware of it and maybe some day we will all include everything without need for database :wink:. Thank you Chris, i believe…

…I forgot to say, using OH and HA in parallel, needs two Controllers.

Well… Not certified, but really, there needs to be a way to differentiate devices. Currently, this is done using the manufacturer ID, product ID, and product type. The problem with everyone adding their own devices is they tend to use manufacturer ID of 0 (which isn’t really valid) and some random product ID and product type. There is no coordination, and therefore if one person adds a device with the same Ids as another person, there is no way to tell them apart (and in fact the database can’t allow this).

So, in reality, this is not easily possible. The best option is to manually create the XML file and add it to your JAR. Alternatively, we need to find some other way to coordinate this sort of thing.

For the Uno, as far as I understand these product IDs can not be changed by the user, so ALL devices will look the same to the binding.