Howto: OpenHAB2, RFXCOM and Somfy RTS Rollershutters

To be honest, I don’t know. I did the pairing using the RFXmngr tool as described in the RFXtrx_User_Guide.pdf file linked by Peter.

I don’t think the OpenHAB RFXcom 1.x and 2.x bindings support pairing of unpaired RTS devices.

Thank you. The tip on converting from Hex to Dec also helped me for my Windows setup.

Thank you for sharing this knowledge. It’s been of great help so far.

However I’ve not been able to control my shutters using OpenHAB2:

  • I have debugging for RFXCOM enabled. Using the karaf console I execute a log:set DEBUG org.openhab.binding.rfxcom

  • My two RFY actuators are always Offline, though the RFXCOM USB transceiver Thing is Online. Are the actuator Things supposed to get Online?

  • I’ve tried using the deviceId 066567.1 and 66567.1, but the signal does not arrive.

  • My two actuators are successfully controlled using RFXMGR from a Windows machine and are listed properly when using the List command:

Packettype        = Interface Message
subtype           = RFY remote:1 ID:01 09 09 unitnbr:1
Packettype        = Interface Message
subtype           = RFY remote:3 ID:01 04 07 unitnbr:1
  • The RFXCOM is successfully connected:
017-05-30 22:18:56.905 [DEBUG] [g.rfxcom.handler.RFXComBridgeHandler] - Checking RFXCOM transceiver connection, thing status = ONLINE

Any ideas what could be the problem?

I don’t know why, but with the current openHAB 2.1 snapshot build #938 the RFXCOM USB Transceiver appears offline, even though it is working. My FRXCOM Rfy Actuator Things are also marked as offline but I can control my rollershutters without any problems using the Control menu in Paper UI.

You don’t need to specify the leading zero, so 66567.1 should be fine.

Are you receiving any other things in your inbox, e.g. temperature sensors using the RFXCOM?

Thanks for your reply. I’ve tried upgrading to the latest snapshot build, but I broke OH2. Maybe upgrading to the latest & greatest will fix this issue… Good to hear that the device being marked offline is not an issue.

That happened to me as well. If you still didn’t completely remove openHAB yet, then you may be able to fix it using these steps.

It’s working now, and devices show online! :slight_smile: What I changed was:

  • Upgraded to latest OH2 (had to clear my cache folder before it would start again)
  • Connect the Rfy actuators to the correct bridge using the Thing edit screen in Paper UI
  • Remove leading zeros from the number, as you suggested

Good to hear that it is working. And good to know not to use leading zeros. I’ll update the guide with that remark. Thanks!

I’ve a question which isn’t specifically openHab related but is related to the setup described in the tutorial.
The RFXtrx433E manual states that to link (pair) the Somfy shutters with the RFXtrx433E, you need to remove the power to all of the Somfy shutters except the specific one you are pairing.
I’ve got quite a few shutters and I really don’t want to spend a day up a (very high) ladder trying to connect and disconnect the power from a very inaccessible part of each of the shutter mechanisms.
Is there a way around this? I can’t see that there is but I thought I would ask.


I don’t think there is a way around this. The problem is that other shutters go into program mode unintentionally and then you accidentally program more than just the one shutter that you’d like to program.

Is it not possible to disconnect them where they are connected to mains power? Mine are all connected to mains behind power sockets. So “all” I have to do is remove the power socket from the wall and I can disconnect them from mains. Still not a lot of fun, but I don’t have to climb any ladders.

Before going up the ladder make sure that you think through how you want to control your shutters. I currently control each individually, but I had to put in a delay of 300ms between each command. Otherwise it seems that congestion occurs and some will not receive the command (and even with the delay some miss the command every now and then).

If I remember correctly then each shutter allows up to 16 transmitters to control them. So you can assign each shutter a unique ID to control it individually, and you can assign them ID’s that they share with other shutters so that you can control all of these with only one up/down command. Then you don’t have the problem of congestion.
Think of groups like all shutters that you want to close to block out the sun, groups of shutters that you want to control when it gets dark, etc.

I still need to program the ‘group’ ID’s but keep postponing it because it’s such a nice job to disconnect them all :slight_smile:

1 Like

Thanks for that. I’ll have to see where the wiring goes.

I understand the delay. I’ve also got some Bubendorff roller shutters and I’ve added a delay for that when closing more than one at once.

I want to be able to open and close shutters depending on where the sun is so the house isn’t in darkness but remains as cool as possible when it’s hot - like now.

Thanks for the info about the group IDs - I’ll read up about that.

I just Added my somfy shutters to openhab, without having to disconnect any of them from power. However, I have separate remotes (or separate channels on one remote for two of them) so pressing the program button only triggers one shutter. If your setup is like this you’re good to go, but I guess if you have several shutters controlled by one remote, and wants to be able to control them individually, then you have to break power to the rest while you program one.

The group IDs are not real group IDs. You just assign multiple shutters the same ID and then when you address that ID you automatically control multiple shutters (as if they belong to a group).
There is no such thing as a Somfy group ID. Sorry for causing some confusion there.

I actually tried that before and ended up with some of my shutters being controlled by the wrong remote. May be I was simply moving too quickly from one shutter to the next. In the end i ended up disconnecting them all to fix things.

That’s weird… I just followed somfy’s instructions for adding a second remote, and it worked for me. It could be worth a try @Saracen before you start climbing at least :wink:

1 Like

I’ll try that. I have some remotes that control shutters in groups but each shutter has at least one remote that it controls individually.


Yes, it worked perfectly. With RFXmngr running, on a PC, for each shutter, I just pressed the existing remote ‘program’ button, pressed transmit (program) on the RFXmngr and that was it. No ladders!

But I do have a question, The control from openHAB works in BASIC UI with items set as rollershutters but is there a simple widget in a similar fashion I can use in HABpanel? I couldn’t find one that would work.
I just need UP/DOWN and STOP. I plan to do the clever stuff in rules.

Good to hear that you didn’t need to climb the ladder :slight_smile:
I have not done much with HABpanel yet, but there seems to be a widget available:

1 Like

Thanks for the link to the widget. It works perfectly. I spent ages searching for one -not sure why I didn’t find that one.


my problem is, that I want to use the >2 seconds command to open or close the rollershutter completly, but I cannot find any buttons or when I am pressing the button longer the rollershutter just make little steps. So does anybody know how to use the longer than 2 seconds command?

1 Like