Howto: OpenHAB2, RFXCOM and Somfy RTS Rollershutters

The group IDs are not real group IDs. You just assign multiple shutters the same ID and then when you address that ID you automatically control multiple shutters (as if they belong to a group).
There is no such thing as a Somfy group ID. Sorry for causing some confusion there.

I actually tried that before and ended up with some of my shutters being controlled by the wrong remote. May be I was simply moving too quickly from one shutter to the next. In the end i ended up disconnecting them all to fix things.

That’s weird… I just followed somfy’s instructions for adding a second remote, and it worked for me. It could be worth a try @Saracen before you start climbing at least :wink:

1 Like

I’ll try that. I have some remotes that control shutters in groups but each shutter has at least one remote that it controls individually.

Thanks

Yes, it worked perfectly. With RFXmngr running, on a PC, for each shutter, I just pressed the existing remote ‘program’ button, pressed transmit (program) on the RFXmngr and that was it. No ladders!

But I do have a question, The control from openHAB works in BASIC UI with items set as rollershutters but is there a simple widget in a similar fashion I can use in HABpanel? I couldn’t find one that would work.
I just need UP/DOWN and STOP. I plan to do the clever stuff in rules.

Good to hear that you didn’t need to climb the ladder :slight_smile:
I have not done much with HABpanel yet, but there seems to be a widget available:

1 Like

Thanks for the link to the widget. It works perfectly. I spent ages searching for one -not sure why I didn’t find that one.

Hi,

my problem is, that I want to use the >2 seconds command to open or close the rollershutter completly, but I cannot find any buttons or when I am pressing the button longer the rollershutter just make little steps. So does anybody know how to use the longer than 2 seconds command?

1 Like

Hi,

Does anybody knows how I can retreive the code of my somfy rts motors without having a computer with windows for rfxmnger?

I’m pretty new to openhab, my setup is a raspberry pi 3 with rfxcomm transceiver. And openhab2 with the rfxcomm binding and somfy urtsi II binding.

Looking forward for some tips.

1 Like

As I remember you can use the rfxmnger with wine on linux.

Hi Stefan @bigi,

I have the same question, with nearly the same setup, when I press the “Up” or “Down” buttom in “controls”, the rollershutter just make a step of 0,5 sec. So to roll out or in I have to press many times… Did you find a workaround ? If not, anybody knows how to configurate the rollershutter ?

Thanks in advance, regards,
Tjerk.

Hi Tjerk,

sorry for my delay, but the summer in Germany was so great that I was not online the last 6 month :wink:

I was working on a workaround a few month before and I started yesterday with the version 2.3 from openhab, but unfortunately nothing has changed since version2.2.

So the best way is to start a pull request for the rfy - RFXCOM Rfy Actuator to add the european configuration. I will inform you when it is done.

As this howto worked for me some month ago I ran into problems when I tried to reinstall the openhab server onto another hardware.
On the new systems (raspberry and qemu) I get the following error about string-conversion while trying to send a command (up/down/stop) to the shutter:

2019-01-03 19:24:00.965 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.rfxcom.handler.RFXComHandler@69f6c165': For input string: "‭‭327237‬"
java.lang.NumberFormatException: For input string: "‭‭327237‬"
    at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65) ~[?:?]
    at java.lang.Integer.parseInt(Integer.java:580) ~[?:?]
    at java.lang.Integer.parseInt(Integer.java:615) ~[?:?]
    at org.openhab.binding.rfxcom.internal.messages.RFXComRfyMessage.setDeviceId(RFXComRfyMessage.java:155) ~[?:?]
    at org.openhab.binding.rfxcom.internal.messages.RFXComDeviceMessageImpl.setConfig(RFXComDeviceMessageImpl.java:39) ~[?:?]
    at org.openhab.binding.rfxcom.internal.messages.RFXComRfyMessage.setConfig(RFXComRfyMessage.java:1) ~[?:?]
    at org.openhab.binding.rfxcom.handler.RFXComHandler.handleCommand(RFXComHandler.java:71) ~[?:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:?]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
    at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [102:org.eclipse.smarthome.core:0.10.0.oh240]
    at org.eclipse.smarthome.core.internal.common.InvocationHandlerSync.invoke(InvocationHandlerSync.java:59) [102:org.eclipse.smarthome.core:0.10.0.oh240]
    at com.sun.proxy.$Proxy124.handleCommand(Unknown Source) [206:org.openhab.binding.rfxcom:2.4.0]
    at org.eclipse.smarthome.core.thing.internal.profiles.ProfileCallbackImpl.handleCommand(ProfileCallbackImpl.java:75) [109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
    at org.eclipse.smarthome.core.thing.internal.profiles.SystemDefaultProfile.onCommandFromItem(SystemDefaultProfile.java:49) [109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:?]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
    at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [102:org.eclipse.smarthome.core:0.10.0.oh240]
    at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [102:org.eclipse.smarthome.core:0.10.0.oh240]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
    at java.lang.Thread.run(Thread.java:748) [?:?]

Does someone else have this kind of problems or has a hint for me? I did some investigations and searches but found just problems that are already solved or usermistakes.

(The other bindings are runing fine on OH2.4 like homematic)
Thanks!

Hello everyone,
Thanks for this tutorial! Helped me get this set up. I wonder if you can help me extend it by detecting button pushes from my Somfy remotes.

Here is the reason - I have two blinds and two Somfy remotes which are attached to the wall and control each blind. This means the blinds get out of sync with openhab; if I press the remote button openhab doesn’t capture that the blinds are up. What I’d like to do is trigger blinds down as part of rules so I can do things like disable the bell noise when the blinds are down in the nursery so as not to wake my little boy (but flash the lights instead)

Thanks!

I don’t think this is possible. For as far as I know, the RFXCom does not receive the RFY signals from the other remotes. @bweijenberg is this correct?

That’s right. Somfy RTS receive is not implemented for two reasons.
1 for security so that Somfy RTS commands cannot be replayed
2 Somfy RTS operates at 433.42MHz and this would need a dedicated receiver.

Solution:
Use a standard 433.92MHz wall switch to send open/close commands and transmit the Somfy RTS command by openHab on command of the 433.92MHz wall switch.

1 Like

To the Somfy Experts:

Is there a way of finding out the code for a particular shutter when the unique shutter code has been ‘lost’?

One of my shutters stopped working - I can control it as part of a group from a Somfy remote but I cannot separate it out to a single shutter to control with the remote so I cannot control it again from openHAB.

Additionally, I also have two shutters that have the same code so they go down and up together - they are in separate rooms on separate house floors. Is there anyway to fix this too?

I understand I can link a remote to a shutter by disconnecting all the other shutters from the electricity and then start the linking process. The problem with this is that all the shutters are hard-wired to the electric supply and there are 22 of them and some of them would require ladder access to get to the wires.

I think I don’t have any options but I thought I would ask!

For anyone who comes here, also wondering why the rollershutters are taking steps of 1 second instead of just going down; this means its in programming mode, to determine the limits. After I configured the limits with an original remote control, I could press up or down in Openhab just once for it to completely go up or down. Even home (pressing stop while its stopped) works fine.

Next to that, you don’t need RFXcom utility to pair, just set it in pairing mode by holding the motor head button for a few seconds until it jugs, and then fire away the Program command channel (create an item for it and then select it in PaperUI control).

2 Likes

I finally got my RFXtrx433XL working with my shutters, the only thing i want is to track how far my shutters are down or up, but the only thing i get back is 0 or 100, if i send 50, it doesn’t do anything.
anyone got an idea?

For as far as I know Somfy RTS shutters don’t support this. You can only completely open or completely close them. I think the ‘newer’ (mine are almost 18 years old) also support a programmable ‘my’ position on the Somfy remote, but I’m don’t know if the RFXtrx433E/XL support this option.