HRT4-ZW Thermostat


I’m new to OpenHAB but have been using Home Automation products for a good few years now. As per the subject title I have an issue with the HRT4-ZW thermostat. I’ve got the thermostat configured and can see information being update. The issue I have is that the reported ambient temperature is reporting correctly in Celsius but the Heating SetPoint is in Fahrenheit.

So at the moment I’m not able to update the SetPoint on the thermostat using OpenHAB.

Can anyone help?

Have you tried setting the setpoint to use celsius (I think this is what you want to do?) using the binding option setpoint_scale? I don’t have zwave thermostats myself so can’t confirm this works…

Thanks for the reply.

From what I can gather yes I have everything setup correctly. Here’s my binding:


Any other pointer?



Maybe I misread your post but I thought you wanted it to report in Celsius? If so, this should be set to 0.

Thanks Chris,

That worked. I can now change the SetPoint within OpenHAB. Happy days.