HS3SA-Z Smart Smoke Detector shows up as HS1SA-Z

I finally managed to fully include a HS3SA-Z Smoke detector.
However it shows up as the older HS1SA-Z Smoke detector.
I’ve experienced multiple issues:

1. Unsupported command class

During the frequent wake ups I got these Unsupported command class messages

2021-08-25 07:36:00.556 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 66: Unsupported command class COMMAND_CLASS_TRANSPORT_SERVICE
2021-08-25 07:36:00.556 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 66: Unsupported command class COMMAND_CLASS_SECURITY_2
2021-08-25 07:36:00.556 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 66: Unsupported command class COMMAND_CLASS_SUPERVISION

2. Mismatch between GUI and node.xml

The node.xml also does not match the thing properties from the GUI:
Node_66.xml (7.8 KB)



    zwave_class_basic       BASIC_TYPE_ROUTING_SLAVE
    zwave_class_generic     GENERIC_TYPE_SENSOR_NOTIFICATION
    zwave_frequent          false
    zwave_lastwakeup        2021-08-25T05:51:54Z
    modelId                 HS1SA-Z
    zwave_version           0.0
    zwave_listening         false
    zwave_plus_devicetype   NODE_TYPE_ZWAVEPLUS_NODE
    manufacturerId          0260
    manufacturerRef         8002:1000
    dbReference             530
    zwave_deviceid          4096
    zwave_nodeid            66
    vendor                  Heiman Technology Co. Ltd
    defaultAssociations     1,2,3
    zwave_routing           true
    zwave_plus_roletype     ROLE_TYPE_SLAVE_SLEEPING_REPORTING
    zwave_beaming           true
    zwave_secure            false
    zwave_class_specific    SPECIFIC_TYPE_NOTIFICATION_SENSOR
    zwave_manufacturer      608
    zwave_devicetype        32770

3. Lifeline can’t be set to controller
It somehow shows an empty filed and changing it does not change anything


4. Changing the wakeup interval does not work
I tried to change the wake up interval but it seems to be rejected by the device

5. It doesn’t send values
I haven’t received a battery report or any other value from the device yet

6. Logfile of my many wake up tries (rename extention to .7z, NODE 66):
zwave.log.7z.txt (655.0 KB)

Would you mind taking a quick look at this?
Is this a database issue or is it just a bad device?
Can I do anything to add the device to the db?

It’s a little strange as the device seems to report that it’s not listening. This means the binding likely tries to send data to it immediately, and then if it really is a sleeping device, it will be asleep and doesn’t respond. Is it running on batteries or mains? Is it possible for it to run on mains? Can you provide the XML?

It can only run on batteries.
I’ve provided the xml under 2. in the post. However the values from the xml do not line up with the values from the gui.

I got a new device and this device wakes up properly.

Here is a new .xml file. Any Chance it’s possible that the device can be recognized under the correct Name HS3SA-Z instead of HS1SA-Z?
node_67.xml (9.1 KB)

It looks like the HS1SA which was added to the database 3 years ago is using exactly the same IDs, so the only way we can potentially differentiate the devices might be the application version. Your device shows as 3.1, but I don’t know if the older version maybe is V1.x?

Other than the name, is anything different? Does the device work correctly? I don’t want to break the device for others to get it working for you, but maybe if someone else has the HS1SA they can provide their XML?

It’s working fine after the replacement. This is more a cosmetic issue - so no worries.
Maybe someone who recently bought a HS1SA-Z can upload the .xml file - maybe it’s really possible to differentiate between versions.

Hi @Spaceman_Spiff and @chris,

I have nine of them. I am at work, so I can send some screenshots of the Thing properties. If it does not help, I can send the XML later.

What do you think?


Thank you for your help and quick reply!
Unfortunately the screenshots are not enough.
It would be nice if you can post two or three xmls.

1 Like

Will do later. Stay tuned. :grin:

1 Like

Ok, shortened my lunch break. :slight_smile:

Here are all XMLs I have regarding the smoke sensor.
network_f2d7d4cc__node_49.xml (10.1 KB)
network_f2d7d4cc__node_50.xml (9.1 KB)
network_f2d7d4cc__node_51.xml (9.7 KB)
network_f2d7d4cc__node_54.xml (9.7 KB)
network_f2d7d4cc__node_55.xml (10.0 KB)
network_f2d7d4cc__node_57.xml (9.1 KB)
network_f2d7d4cc__node_58.xml (9.5 KB)
network_f2d7d4cc__node_61.xml (10.0 KB)
network_f2d7d4cc__node_62.xml (10.6 KB)

Thanks @HFM for providing the XML files. Unfortunately they show that the device presents exactly the same information as @Spaceman_Spiff HS3SA so there is absolutely no way to tell these two devices apart.

All I can therefore offer is to change the name of the device in the database from HS1SA to HS1SA/HS3SA.

1 Like

I think that is a good approach. For me is the model not so relevant (probably for many people).

Have a good evening!

I think it’s good, too.

1 Like

I’ve just bought 2 of these HS3SA-Z devices.
I can’t seem to get them (both) working in OH3.1.0.

I’ve tried the normal including as with any Z-Wave device, it gets detected but isn’t visable in the z-wave map.
Also it never updates is values (not even after 1 week).

at userdata->zwave there is also no .xml file for the node.
I’ve added the .xml by hand (using the node_67.xml from Spaceman_Spiff) and filled the correct node and network number.
Still no change.

How to include these devices?
Can’t be that both new devices are broken, can it?

I had to send my device back because it did not wake up properly.
So there is at least the possibility that these devices have buggy/bad firmware which prevents them from being included properly because the replacement worked.

Battery devices typically need to be manually woken with the button several times to be fully included. An device not producing a XML usually means it is not yet finished. Another clue is if the “reinitialize Device” is not shown at the bottom of the UI page.


I’ve tried to wake it up several times (by testing the ‘test’ button and/or by pressing the include button 3x in 1,5sec). This doesn’t help.

I’m afraid I have two broken ones or with bad firmware.

Could be right. One last option (if you want to try) is to put the zwave binding in Debug mode then press the test &/or include button. You are looking for a wake-up message from the node. Also try to just press the include button once (sometimes the instructions are wrong about the 3x for wakeup only). Otherwise it is a return to sender :wink:


How do I put it in Debug mode?

Found it. I have to enter the Console by sudo docker exec -it OpenHAB /openhab/runtime/bin/client -p habopen
And there I can enable it with log:set DEBUG org.openhab.binding.zwave and disable it with log:set INFO org.openhab.binding.zwave