HTTP-Binding Switch Configuration throws error

I have the following itemdefinition

Switch TL300A00A02  "Sommerbetrieb [%s]"                        (gLueftungTemp) { http="<[AC40CacheRaw:30000:JS(AC40_TL300A00A02_GetVal.js) >[ON:POST:;nv=ON1] >[OFF:POST:;nv=OFF]"}

I get the follwoing log entry

==> /var/log/openhab2/openhab.log <==

2017-09-19 10:31:24.267 [ERROR] [b.core.service.AbstractActiveService] - Error while executing background thread HTTP Refresh Service

java.lang.IllegalArgumentException: given transformation function 'JS(AC40_TL300A00A02_GetVal.js) >[ON:POST:;nv=ON1' does not follow the expected pattern '<function>(<pattern>)'

	at org.openhab.binding.http.internal.HttpBinding.splitTransformationConfig([185:org.openhab.binding.http:1.10.0]

	at org.openhab.binding.http.internal.HttpBinding.execute([185:org.openhab.binding.http:1.10.0]

	at org.openhab.core.binding.AbstractActiveBinding$BindingActiveService.execute([181:org.openhab.core.compat1x:2.1.0]

	at org.openhab.core.service.AbstractActiveService$[181:org.openhab.core.compat1x:2.1.0]

It seems to be a small error but I can not find it.

Has anyone an idea what is wrong with the definition?

If I ommit the ON and OFF part of the Item definition it is working.

With an number Item it works

Number TestSoll1 "Sollwert [%d °C]"{ http="<[AC40CacheRaw:30000:JS(AC40_Value.js)] >[*:POST:;nv=%2$s]"}

The http help is telling

Here are full item examples of sending content in the body of a POST method (new in 1.9.0):

But I do not see, what am I doing wrong:

Switch TL300A00A02  "Sommerbetrieb [%s]"                        (gLueftungTemp) { http="<[AC40CacheRaw:30000:JS(AC40_TL300A00A02_GetVal.js) >[ON:POST:;nv=:ON1] >[OFF:POST:;nv=:OFF]"}

Switch TL300A00A02  "Sommerbetrieb [%s]"                        (gLueftungTemp) { http="<[AC40CacheRaw:30000:JS(AC40_TL300A00A02_GetVal.js) >[ON:POST:;nv=ON1] >[OFF:POST:;nv=OFF]"}

But I allways get the same error.

Is it not possible to combine “IN <” and “OUT >” direction in the Item definition ?

Problem solved.

I have forgotten “]” after the IN Option.