Hue emulation and openHAB 2.5.0 snapshots above #1512

Up to #1512 everything with Hue emulation service worked out as expected for at least 2 years with many different snapshots of various OH2 versions. Trying higher snapshots than #1512, the service fails to pair and the pairing mode never resets after 60 secs. Today i installed the latest Hue emulation service .jar-file within the snapshot #1512 in the addons folder and it worked out immediately as expected:

285 │ Active │ 80 │ │ Hue Emulation Service

Thus, the issue seems to be outside the Hue emulation service. Run OH2.5.0 #1512 on Windows 10 and have an old 2015 Alexa. Had nothing to set extra, except the pairing switch.

Does anybody have a hint for me where outside the Hue emulation service app the problem could be?

Thanks in advance,

Use the search function of the forum. Just 5 days ago or so someone already posted a topic.

Tl;dr: the hue service is broken due to recent core changes.

1 Like

Thanks David, didn’t see this. Saw many contributuions around port 80 & 8080. The problem is, that its very often not obvious which snapshot people are running and if on Linux or on Windows. Please also understand, that my knowledge is far away from yours as maintainer and author of bindings and services. I am a standard user. But i have 20 Hue emulated devices which are by far not all lights. I use your service for instance to run my hoover or to open my bike garage. Without Hue emulation service, openHAB is only 50% of what it is :-).