Hue emulation stopped working, all devices are of type "various" now

A physical network interface can have multiple IP addresses assigned.
Just add another IPv4 interface or a software network bridge (bridge command on newer linux’s) and let openHAB run own its own IP on port 80 with the hue emulation enabled.

1 Like

I caught a nearby echo doing the LED dance all by itself. I began to worry that Amazon was pushing updates again. Now I find that after ten days of blissful operation, Hue Emulation stopped working again. When I looked at the discovered devices list I saw multiple duplicate entries.

So I’ve gone through the forget devices / rediscovery devices several times. There are less duplicates now, but most items appear twice: Same name but with different descriptions:
Philips Hue White Light
Royal Philips Electronics smart device

Most Hue Emulated devices remain broken. Telling Device “A” to turn on ends up turning on device “B” instead. It seems like OH2’s device map is corrupted.

The recommended fix is to continue to forget/rediscover until things are working again. But I haven’t had success doing that. Is there a revised solution to this?

  • Thomas

@ThomasOH what openHAB version are you. I have seen this behavior on my setup but I believe it went away in 2.5

My configuration is OH2 2.4 Build 1412 with manually installed hueemulation 2.5.0 (snapshot).

1 Like

hue emulation 2.5m1+m2 had this problem and it is fixed since m3.

That is fantastic. Since I’m still on OH 2.4, any chance there’s a public repository with the compiled m3 jar I can download?

  • Thomas

So can anyone speak to why the 2.3 version of Hue Emulation has gone dead? Was there a change in firmware of the Amazon/Alexa side that preventing communication? I have an almost 2 year stable install go silent and unable to communicate with Alexa.

That’s an interesting question. I’m on 2.4 and questioning the same. Is it enough to install hue emulation binding 2.5 M3 to fix the issues? Are the devs aware of the issues?

I have posted on GitHub with the issue…over 2 weeks with no comments. :frowning:

Still looking for a M3 jar to try out. BTW, I did some digging and a recent discussion has comments that suggests that all 2.5 milestones have hue emulation problems. See the dialog deep in this:

Can someone confirm that the m3 hue binding is a winner?

  • Thomas

The new code is a rewrite. It does behave different (emulating a V2 hue bridge with a 2018 firmware). But at some point you just don’t have a choice. The V1 bridge is EOL and Alexa and Co might not support that anymore at some point.

Because the hue V2 bridge supports https encryption, which requires a few specific keys to be set in the certificate, it is not necessarily easier to set that up. https is not yet required though as far as I know.

Cheers, David

1 Like

Then 2.5 M3 hue emulation and following release is the way to go? And where do we get it manualy, for a 2.4 stable install? Or do we have to install OH 2.5 betas?

I do not use Hue emulation and can not confirm that the version in 2.5M3 would fix your problem. If you decide to try the latest version (at your own risk), I would strongly suggest you make a full back up of your 2.4 installation before trying in case you need to revert back to your old version.

I decided to upgrade my 2.4.0 snapshot (build 1412) to 2.5 m3. Spoiler alert: I failed miserably.

Not a fresh install; I used OH2’s config to upgrade to the latest testing branch. This was my process:

  1. Stopped OpenHab2.
  2. Cleared the cache.
  3. Installed the 2.5 m3 update from config.
  4. Checked all my files in /etc/openhab2 and made sure they were still there.
  5. Rebooted.
  6. Manually set iptables (port 80 fix).
  7. Confirmed boot screen showed new version.

I could not get MQTT v1.x to work (MQTT broker was fine, but OH ignores it). And although Hue Emulation found all my devices after discovery, it still assigned two names to many devices. And none of the devices respond (echo dots respond with the frustrating “check the device” message).

After a couple hours of hair pulling I abandoned the 2.5m3 upgrade. Next I copied its Hue Emulation jar file to my local drive. Then restored my old OH 2.4 system and replaced the existing 2.5 snapshot ( jar file with the new 2.5 m3 jar.

My 2.4 Snapshot system will not run the 2.5 m3 jar that was extracted from the upgrade. It breaks the web interface so I can’t load paperUI.

I’m back to my old 2.4 Snapshot. Hue Emulation was fixed two weeks ago (after manually installing a 2.5 snapshot jar). Then it broke again a couple days ago. Today’s efforts didn’t get me any closer to a fix.

At this point I think the solution is to start with a fresh install of 2.5m3. But I don’t have confidence that Hue Emulation is working correctly on it. As far as I know there’s no authority with a answer on that.

So the big question: Are there any 2.5 m3 Hue emulation users out there with a fully working system? I mean, a system that works as well as we had a month ago before Jeff B’s coders messed up the API?

  • Thomas

if you report your problems in this thread, the developers might be able to use the information to fix the problem

1 Like

@ThomasOH my hue emulation works on 2.5m1. I had trouble on 2.4.

I tried m2 and m3 but had issues with hue emulation. I have been tied up but plan on setting up a dev box soon(2weeks) to test m3 on a fresh install with no other bindings.

I have not seen anyone else complain, but I don’t know who else has tried Emulation on m3, except you. Also I am in the US where r u? Curious I am thinking this may make a difference also.

Regarding the duplicate devices showing up: I found out that (non-functioning) devices re-appear if you do not deleted them one by one via the web-interface. As long as you use “delete all” they come back as duplicates and mess up your setup. Delete them device by device.
It still works for me with the old 2.5 version of the Hue emulation addon.

1 Like

Thank you (again)! That tip is gold. I deleted over 90 devices and a new discovery found 50. That’s a more realistic count.

And I’m back to the working state I had two weeks ago. I still have the bug where Alexa responds to dimming commands with “Sorry, [device name] appears to be malfunctioning.” But the lights reliably dim, so it’s not a big deal. On/Off commands work without any issue (no complaints from the echo dots).

It’s still a mystery why my Hue Emulation went wacky on its own. As I mentioned before, I saw a nearby echo do the ring of light dance late at night. Then the next morning I found Hue Emulation was broken again. My best guess is that something triggered a discovery that went badly.

  • Thomas
1 Like

I’m in the USA (west coast). Please report back after you test Hue Emulation on 2.5m3.

  • Thomas

Can’t wait for the results.

btw. shouldn’t it be possible to use the 2.5 binding with OH2.4?