Hue emulation stopped working, all devices are of type "various" now

Thomas, can you let everyone know what you ended up doing to get it working? Your previous post explained what you did that did NOT work, but now it seems you’ve figured it out. So for instance, what version of OH and the Hue binding are you using? And did you have to do anything else besides the port 80 fix and manually deleting/re-adding the devices through the Alexa web interface? Thanks.

Please see my Sep-30-2019 post. It explains everything I did to get Hue Emulation working before the new issue appeared a couple days ago. But that is fixed too, per the new post you read.

BTW, five minutes ago I witnessed a nearby Echo dot do a firmware update. It was on Version 645584020, now it is 647591020. I don’t dare try a new discovery since it seems Jeff B. and his coding friends are out to get me.

  • Thomas

There are also encoding problems in the discovered device names now: German umlauts (ä, ü, ö) are broken und Alexa then does not understand the names.
A workaround is to manually fix the broken names in the Alexa App.

The situation seems to get worse day by day.

1 Like

Philips added window blinds and wall sockets to the protocol. So Amazon needed to upgrade their Hue support. That’s my guess.

German umlauts (ä, ü, ö) are broken

Hm. Hue emulation does not send any encoding header, but it will send utf8 characters. That’s usually java’s default. Maybe we should start to send a utf8 encoding header.

btw. shouldn’t it be possible to use the 2.5 binding with OH2.4?

No. 2.4 and 2.5 are mostly incompatible. The dependencies have changed too much.


Thank you soooooo much!!! I had the same issue and had to redirect to port 8080. This solved the problem i had.

again, thank you!!

Anybody got it (fully) working again?

My Hue Emulation still doesn’t work. Devices are detected as type “various” (“Sonstiges”). No control via app and no control via voice.
I am running openHAB 2.5.0.M4. Port redirection and various times deleting and searching didn’t help.

@haribo I have retained myself on 2.5m1 as the m2 and m3 release seemed to cause problems for me.

I have not tried the m4 release yet.

@lopez1de 2.5m1 works for me. Have you tried it?

I don’t know how to downgrade. Would the M1-Version of hueemulation be compatible to a M4 openhab system and where would I find the file (
I found but only M2,M3 and M4 are listed.

I know you can install the full package using apt. Don’t remember the exact command right now.

Not sure if you can do just the jar file.

Your m4 setup should work on m1, unless you are using something that was added or fixed in m4.

Have a look here

Hi all,

just for your Info as it might be interesting for other 2.4 Stable (2.4.0-1) Users as well……

I only had to apply the port forwarding from Port 80 to 8080 as described in various comments before
sudo iptables -A PREROUTING -t nat -p tcp --dport 80 -j REDIRECT --to-ports 8080
(See for example the post from 1st Oct 6:37 from ThomasOH).
Afterwards in PaperUI -> Configuration -> Services -> Hue Emulation -> Configure
Pairing timeout = 90
Optional discovery web port = 80
Device Paring = Activate
And Click on “Save”. Now you have about 30 Seconds ( or prepere before) to logon to (or appropriate .com etc.). Click on Smart Home, Geräte/Devices -> Suche/Search. (via App it was not working)

Items defined in /etc/openhab2/items like
Switch Jalousie “Jalosie” [ “Lighting” ]
were discovered without issues again.

Yes I still had issues with some items only defined in PaperUI but not sure what was/is the problem here. I also still have issues with “German umlaut“ like Küche (Kitchen) but this is something I can manage.

I.e. NO manual update of HueEmulation Binding from default OH 2.4 was required! Maybe this was already known to you but but by reading all the previous post it was at least not clear to me.

Regards, Thomas

PS: Using an Echo Dot Gen 1. (Sw 647642120) + Gen 3. but it is working with both.

Thank you for the summary. But does it fix the problem that alexa says that something is wrong with the device after setting a light (dimmer) to a specific value?

I don’t have dimmers in use but as short test I added

Dimmer myDimmer “myDimmer1” [ “Lighting” ]

to hue-test.items

  • Enabled Pairing

  • I could see the new item myDimmer1 in http:///api/status.xml (just for verification purpose)

  • Enabled Parining

  • Did a search in

  • Discovered new Device

  • Renamed myDimmer1 to Dimmer in AlexaApp (myDimmer1 was not a good idea as name to be recognized by Alexa)

  • Switch off/on via Alexa works fine

  • Command to set to 50% does work but still get a message from Alexa like “does not work” although value 50% was received by OH as seen in event.log

Regards Thomas

1 Like

Thank you for testing Thomas. This is the same problem I’m facing. FYI I’m on version 2.4 also.

I was a happy Hue Emulation for quite some time but have been without for the last 60 days or so…

I’m running a snapshot of OH 2.3 which had been very stable for me for quite some time.

I’m on a Windows server and all of my Hue Emulation devices show “Server is Unresponsive” in the Alexa app.

I have added a port forwarding rule on the router to forward port 80 traffic to 8080.
I have enabled device discovery in in PaperUI
I have changed the discovery web port in PaperUI to port 80
All of my devices are shown using status.xml

Still nothing…devices are not accessible to Alexa

Did Amazon make a breaking change that the version of Hue Emulation I’m using will no longer work?

I noted an issue on GitHub over 2 months ago with no responses…

Looking for any guidance.


I believe the answer to did Amazon change is yes. I am fairly certain 2.4 or 2.5 m1 is the minimum version for hue emulation to work. This is due to fixes for changes Amazon made.


Think I could place the newer version of the binding in my addons folder or are their dependencies I might need??

Unknown to me. Sorry

Well I have tried by adding a 2.4 and 2.5 version of the Hue Emulation service and Alexa can still not see any of my devices…they all show Server is Unavailable in the Alexa app. This seems like a firewall issue to me, but everything looks good.

Any suggestions greatly appreciated.

Squid :squid: