Hue emulation stopped working, all devices are of type "various" now

Looks like someone saw something in the code, and has submitted a fix!!! Huzzah!!!

Great news! Maybe now the newer 2.5 versions will work for me also.

@KidSquid I tried the jar file on 2.5m5 and it worked for my test item.

I will try to restore a backup of more items tomorrow.

1 Like

@Thedannymullen Hey, any updates on your test with 2.5?

Yes the new jar file works, but alexa gives an error. I have been using anyway even though she says I am sorry something happened.

@lopez1de I am running 2.5m6 emulation.

I am working, some commands receive an error from alexa but work fine. Could be a sluggish network connection because it is intermittent.

Good news is it does function.

Bad news to get it to work, I had to rebuild from the ground up. Meaning I manually moved my config files over one at a time. No matter how hard I tried if I did a restore of my backup zip file I could not get a working system. If you use paper ui I suspect thing may be ok.

2.5 is out. Any good news for this topic?

2.5 is working for me. I still have the port redirection in use, but I’m not sure if it is still needed.
Dimmer-/Lighting-Devices still lead to the “device is not working properly” message.

Upgraded to OH 2.5. It’s still exactly the same problem. I need to use port forward 80 to 8080. Devices are discovered as “Royal Philips Electronics intelligentes Gerät” and I can use them, but Alex says “***** scheint nicht richtig zu funktionieren” (eng: “**** is not working properly”.

Same with me on 2.5. (Rasp 3B+, openhabian, Echo Dot Gen 2)
Even Controlling the Rollershutter (Dimmer item) works properly, but Alexa responds with “does not work properly”.

One more thing.
I have a Harmony hub and can switch the lamps OFF with the home control buttons on the remote (long button press), but cannot switch them ON (short button press).
This used to be working, because they are found as Hue Devices as well.

After my update to 2.5:
I still get the “device is not working properly” problem for dimmers - apart from that everything works as it should.

Post update, I removed every device (one by one) via the alexa.amazon.com web UI and then rediscovered them all.
My OH setup runs on port 80 and I changed the “Optional Discovery Web Port” in the Hue Emulation settting to port 80 to reflect that.
I have no port-forwarding to 8080.

Do you know - is there already an issue raised in Git to reflect the “device not working properly problem”?

1 Like

I have done some further playing around, to see if I can gather some information which might be helpful.

My test setup:

  • a dummy Dimmer item Dimmer DTest "Test" (GDebug) ["Lighting"]
  • this item can be controlled via Alexa via voice
  • I can verify via the JSON from the API (http://192.168.2.200/api/testuser/lights/69), that the bri-value changes according to voice
{
  "state": {
    "bri": 206,
    "ct": 500,
    "on": true,
    "reachable": true,
    "mode": "homeautomation",
    "alert": "none"
  },
  "type": "Color temperature light",
  "modelid": "LTW001",
  "uniqueid": "02c09d5c-3116-4074-9720-0b2ba01cbf3f-69",
  "manufacturername": "Philips",
  "swversion": "66012040",
  "friendsOfHue": true,
  "colorGamut": "2200K-6500K",
  "hascolor": false,
  "name": "Test",
  "config": {
    "archetype": "classicbulb",
    "function": "functional",
    "direction": "omnidirectional"
  },
  "capabilities": {
    "certified": true,
    "streaming": {
      "renderer": false,
      "proxy": false
    },
    "control": {}
  }
}
  • I can also see the change in the slider representation in the HTML sitemap

The following is a list of voice commands // the log statement // the JSON // the response from Alexa:

  • “Alexa, schalte Test ein” // log: DTest changed from 0 to 100 // JSON: “bri”:254 // no error from Alexa
  • “Alexa, Test auf 50%” // log: DTest changed from 100 to 50 // JSON: “bri”:127 // “Test scheint nicht richtig zu funktionieren”
  • “Alexa, Test auf 51%” // log: DTest changed from 50 to 51 // JSON: “bri”:130 // no error from Alexa
  • “Alexa, Test auf 52%” // log: DTest changed from 51 to 52 // JSON: “bri”:132 // “Test scheint nicht richtig zu funktionieren”
  • “Alexa, schalte Test ein” // log: DTest changed from 0 to 100 // JSON: “bri”:254 // no error from Alexa
  • “Alexa, Test auf 51%” // log: DTest changed from 50 to 51 // JSON: “bri”:130 // no error from Alexa
  • “Alexa, Test auf 0%” // log: DTest changed from 51 to 0 // JSON: “bri”:0 // “Der Wert liegt außerhalb des Bereichs für das Gerät Test”
  • “Alexa, Test auf 1%” // log: DTest changed from 0 to 2 // JSON: “bri”:5 // “Test scheint nicht richtig zu funktionieren”

What do I take from that?

  • all commands make the item itself do what it should
  • but most of the time, Alexa claims that something went wrong
  • many “set Test to xx%” values result in Alexa claiming: “… appears to be malfunctioning” (note: this may not be the correct English translation, I am only sure about the german voice output)
    but some values (51%, also 74% - probably others too) do not result in such an error output
  • when setting the value to 0%, Alexa claims: “this value is outside the range of the device” (again: this may not be the correct English translation)

As some numbers work and others don’t, I suspect that the problem could be connected to some rounding issues, but that is for someone else to really inspect and find out - my coding skills are way to bad to do it myself.

If you have any hints what more research I can do and also where to properly raise this issue, please let me know, @Thedannymullen, @lopez1de, @NCO, et al.

1 Like

I checked all open issues for hueemulation and as I did not find anything covering this topic, I raised a new issue:

1 Like

I had some issues persist through an upgrade as well - I removed the hue emulation service, deleted all associated json files, unplugged echo dots for a few hours, removed all devices from Alexa web page, and finally reinstalled the hue emulation service. Once it was reinstalled I plugged in one echo and ran discovery. Everything seems ok now.

I’m on 2.5 too and can reproduce all these errors as described.

Thanks @bastian: I have observed the same responses.
And thanks for opening the issue.

Like described by @bastian?
(Alexa complaining even though it’s working properly)?
I also removed all devices and added them again, but this issue is thiss there.

@bastian great debug. Your translations were correct I get those responses from time to time.

From what I can tell this is an Amazon issue. I saw a video the other day about using node red for alexa local control. In that live stream she return the same response even though it worked. The video maker said that’s normal right now.

@Thedannymullen How can this be an Alexa issue? Alexa doesn’t show this behaviour with a Philipps Hue bridge v2.

@lopez1de True statement! I did not think of that. Then I am lost! I do however know this for sure. Mine is intermittent in when it does it. I from time to time on 2.5m6 get it. Now that I am done with holiday travel I will put the release version on. But on this version the error messages are only there 10-20% of time.