Hue pairing in manual configuration not working

I have been using openHab for a while now with my hue bulbs amongst other things. In order to set up my Alexa skill, I’d like to take over manual control for my hue items instead of configuring them through the Paper UI so that I can assign room groups, etc.

Therefore, I’ve removed all things, items, and the old bridge. Then I added a new .things that looks like this:

Bridge hue:bridge:1 [ ipAddress=""] {
    0100 bulbB [ lightId="4" ]
    0210 bulbC [ lightId="2" ]
    0100 bulbH [ lightId="5" ]
    0100 bulbK [ lightId="3" ]
    0210 bulbL [ lightId="1" ]

As soon as I save the file, I can see in the log file that I am requested to press the pairing button. I press the button and a new user is generated and displayed to me. At that point in time, the bridge is working.
Now, I need to make the user name setting persistent by adding it to the configuration file:

Bridge hue:bridge:2 [ ipAddress="" userName="xxx"] {

As soon as I save the file, the binding starts the process all over again by creating a new user and asking me to press the button. I tried simply not adding a user but then things don’t work as soon as I restart openhab.
What am I doing wrong?

I did the pairing using the auto-discovery from the Inbox. This created a username which I just used to configure the bridge manually.

Thanks, I just tried that but that unfortunately doesn’t work either. I added the bridge in Paper UI, took the generated user name from the log file and then tried to create a new entry in the .things file with either:

  1. The same bridge ID as from Paper UI
  2. With a new bridge ID

neither of them worked. It still shows the second bridge as uninitialized and is asking me to press the button.
I guess I can just add all the things through the Paper UI and then do the item configuration manually…